Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4039971

C Native code within Java application fails under Solaris 2.5.1 ok under 2.5

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.0
    • Fix Version/s: None
    • Component/s: hotspot
    • Subcomponent:
    • CPU:
      sparc
    • OS:
      solaris_2.5.1

      Description

      Customer has developed a piece of java code which includes a piece of C native code. The C native code attempts to open and operate upon the audio device. The whole intent is to be able to open and ultimately use the audio device for recording and playback. This example just tries to open audio.

      Note that the c code will run on both 2.5 and 2.5.1 and that the java example shown here and indicated to be problematic on a 2.5.1 system will run quite well on a 2.5 system.

      I have tried both recompiling on the 2.5.1 system which has java 1.0 installed as well as trying the binary from the 2.5 system. No differences in operation were noted.

      > I got a chance to try this out this afternoon. I first tried without
      > recompiling and then tried again after recompiling on a 2.5.1. system (latest
      > kernel patch).
      >
      >
      > Script started on Fri Feb 28 16:34:29 1997
      > $ java AudioTest
      > AudioTest:Starting record
      > SoundBite.recordSetup(native):Couldn't set Audio Info 1: Invalid argument
      > SoundBite.record():Setup returned FALSE
      > AudioTest:Couldn't Record
      > $
      > $ ls -l /dev/audioctl
      > crwxrwxrwx 1 root other 108,128 Apr 10 1996 /dev/audioctl
      > $
      > $ javac AudioTest.java
      > $ ls
      > AudioTest.class AudioTest.java mail typescript
      > $ java AudioTest
      > AudioTest:Starting record
      > SoundBite.recordSetup(native):Couldn't set Audio Info 1: Invalid argument
      > SoundBite.record():Setup returned FALSE
      > AudioTest:Couldn't Record
      > $ java AudioTest
      > AudioTest:Starting record
      > SoundBite.recordSetup(native):Couldn't set Audio Info 1: Invalid argument
      > SoundBite.record():Setup returned FALSE
      > AudioTest:Couldn't Record
      >


      I will send the source or it can be accessed from:

      /autohome1/gregb/info/code/java/examples/javasrc/medicalCollab/test

        Attachments

          Activity

            People

            • Assignee:
              sliangsunw Sheng Liang (Inactive)
              Reporter:
              gbedigia Gregory Bedigian (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported:
                Indexed: