Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4176315

Demo applet has an unlabeled button on x86 only.

    XMLWordPrintable

    Details

    • Subcomponent:
    • CPU:
      x86
    • OS:
      solaris_2.6

      Description


      allan.jacobs@Eng 1998-09-24

      The demo applet for demo/applets/GraphLayout/example1.html has two buttons.
      One of these is labeled Scramble and the other is labeled Shake. The label
      for the "Shake" button is not visible on x86 machines. The visibility is
      fine on sparc. The importance of the bug is that something might be wrong
      in the AWT and it's interface with x86/Solaris 2.6 Motif.

      x86-sirius% uname -a
      SunOS x86-sirius 5.6 Generic i86pc i386 i86pc
      x86-sirius% setenv JDK /net/mulder.eng/export/mulder3/jdk12x/intel/jdk1.2FCS_K
      x86-sirius% ${JDK}/bin/java -fullversion
      java full version "JDK-1.2fcs-K"
      x86-sirius% ${JDK}/bin/java -X
      x86-sirius% setenv THREADS_FLAG native
      x86-sirius% unsetenv JAVA_COMPILER
      x86-sirius% cd ${JDK}/demo/applets/GraphLayout
      x86-sirius% ${JDK}/bin/appletviewer example1.html
      x86-sirius% showrev -a
      Hostname: x86-sirius
      Hostid: 154378d3
      Release: 5.6
      Kernel architecture: i86pc
      Application architecture: i386
      Hardware provider:
      Domain: sunsoft.eng.sun.com
      Kernel version: SunOS 5.6 Generic August 1997

      OpenWindows version:
      OpenWindows Version 3.6 7 July 1997
      Patch: 105491-04 Obsoletes: Requires: Incompatibles: Packages: SUNWcsu, SUNWcsr, SUNWarc, SUNWbtool, SUNWhea, SUNWtoo, SUNWosdem, SUNWxcu4


      allan.jacobs@Eng 1998-10-06

      The demo runs properly with the JDK from Solaris Product Group. It's not a problem
      in the demo itself. Given that the problem is as basic as the labeling of a an
      AWT button and that the demo is much smaller than the bug report JavaSoft is going
      to get from the field, this bug may deserve more than priority 5 attention.

      This is caused by an X server problem on x86 Solaris 2.6. There is now a bug filed about that: 4184869, so I am closing this one as a duplicate.
      hania.gajewska@Eng 1998-10-27

        Attachments

          Activity

            People

            Assignee:
            hgajewsksunw Hania Gajewska (Inactive)
            Reporter:
            ajacobssunw Allan Jacobs (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: