Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4356447

Linux: Styles are not applied to any characters on some AWT components

    XMLWordPrintable

    Details

    • Subcomponent:
    • Resolved In Build:
      linux-rc1
    • CPU:
      x86
    • OS:
      linux
    • Verification:
      Not verified

      Description


      Tested with Kestrel-linux on RedHatLinux6.1J and 6.1J update


      Bold, Italic, BoldItalic styles are not applied to characters on
      Button, Label, Checkbox, RadioButton and TextField.
      Characters set on these components are always Plain.

      This is reproducible with Cricket-linux.

      To reproduce,

      1. Compile an attached test case (StyledFont.java).
      2. Run StyledFont
      3. Then, you can see a Frame which includes the components.
      This test program provides
      4Button, 4Label, 4Checkbox, 4RadioButton and 4TextField on which
      Japanese characters and alphabetical characters set and
      4 style, Plain, Bold, Italic and BoldItaric set to each component.
      However, on Linux all characters are Plain.



      Tested with Kestrel on Solaris, the phenomenon is different.
      Only ASCII characters can be styled.
      Other characters have this problem.



        Attachments

          Issue Links

            Activity

              People

              Assignee:
              sherman Xueming Shen
              Reporter:
              mmtokunasunw Mtokunaga Mtokunaga (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Imported:
                Indexed: