Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4360886

Linux: Java VM process dies in excuting automated applets

    XMLWordPrintable

    Details

    • Subcomponent:
    • CPU:
      x86
    • OS:
      linux

      Description


      Tested with j2sdk 1.3.0 rc1 build b14 on RedHat6,1J and 6.1J update


      Java VM process sometimes dies in excuting applets with automated program.


      To reproduce,

      1. Install Java Plug-in by excuting jre1.3/package or jdk1.3/jre/package.
      2. Launch Netscape.
      3. Go to the url,
      http://javaweb.eng.sun.com/~vmanda/automated/apache_https/index-tour.html

      Going to this link, testing applets for https are excuted automatically one by one.
      While excuting applets, an error occurs and Java VM process dies.
      An error message is output on terminal.
      It does not occur every time the automated program is excuted, but somtimes occurs.

      The deatil of the error message is;

      #
      # Problematic Thread: prio=1 tid=0x8212190 nid=0x606 runnable
      #
      Read of acknowledgement failed: 4
      Plugin: Plugin is not enabled or Java VM process has died.


      When the error occurs, Netscape is not hung and reloading the page, Java Plug-in works again.



      -----miki.tokunaga@japan 2000-08-23-------------------------------------------

      Web Server is up now though it seemed to be down when I tested this case yesterday (---I do not have a permission restart the server).
      This problem is reproducible with b16.
      Could you please try testing again?
      ______________________________________________________________________________

      I tested the automated test case located at
      http://javaweb.eng.sun.com/~vmanda/automated/apache_https/index-tour.html
      and this bug was reproducible though it was intermittedly.
      I tested it with strace and got a trace file.
      I attached it to this bug report (4360886.trace.gz).
      If the file is useful to investigate the problem, please see it.

      miki.tokunaga@japan 2001-01-19
      ______________________________________________________________________________


      I re-tested with Ladybird b19 on one RedHat6.1J update machine and two 6.2JUpate
      machines.
      I run the automated test for several times on each machine and the problem was
      not reproduced.

      miki.tokunaga@japan 2001-03-16
      ______________________________________________________________________________

        Attachments

          Activity

            People

            Assignee:
            jmelvin James Melvin (Inactive)
            Reporter:
            mmtokunasunw Mtokunaga Mtokunaga (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: