Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4371576

Netscape 4.7/4.75 hangs with Java Plug-in 1.3 applets

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: 1.3.0
    • Fix Version/s: 1.3.1
    • Component/s: deploy
    • Subcomponent:
    • Resolved In Build:
      1.3.1
    • CPU:
      generic
    • OS:
      windows_nt

      Backports

        Description

        Customer Problem description:
        ------------------------------

        After accessing our html page with multiple instances of our applet in it in a
        Netscape window using frames. Without touching anything in the applet's frame,
        clicking a link in the left frame or the browser's back button causes Netscape
        to hang.

        It works fine when using one applet in a non-frames window.

        I've tried using a page with multiple instances of our applet in a non-frames
        window. Then accessing other URLs works, but Netscape sometimes crashes when
        returning to the page with the applets.

        The applet uses swing components (JEditorPane, JScrollPane, JMenuBar, JMenu) and
        Netscape's JSObject.

        We're using Java Plug-in 1.3 on Windows95 and Netscape 4.7/ 4.75

        This is the URL to the test site: http://www.greatconnect.com/SunStorage

        1. Select Publish under User View:

        2. navigate to Tasks -Updates, using link at left.

        3. and supply the following info:


        for form login use
          email: xxxx
             pw: xxxx
        ( i will send the abaove info separately to the resp engr)
             
             
        choose one from resulting list.


        Here are 1 - 4 of 4 previously submitted documents under your account:

          1.Concept - Product, task no. 1, 2000-08-02 13:01:25
          2.Concept - Product, task no. 2, 2000-08-02 13:05:10
          3.Concept - Product, task no. 3, 2000-08-02 13:10:34
          4.System Test - Product, task no. 99, 2000-08-31 15:37:32

        I noticed that the applets that aren't being displayed because they are
        farther down the page don't fully load until I scroll the window to show
        them. Then they load and start.

        If I don't scroll the window to show the applets (to make sure they've
        started), then click the back button or other link Netscape hangs. This only
        seems to happen on the Task pages and not the Chapter pages. Very strange.
        The EMBED tags are nearly identical (only minor parameter values are
        different) in the files.

        Our problem seems like the Plug-in or JRE is still processing or not
        relinquishing control when Netscape removes the current page and goes to get
        the new one. It appears to be trying to get the new page, but never does and
        is unresponsive to the stop button or anything else.

        The problem can also be seen at the following urls:

        Here is a URL using the html file I attached as a test with a static
        page without frames: http://216.147.49.144/SunNS/AppletTest/TaskT1.htm

        I made two more html test file based on TaskT1.htm:
        http://216.147.49.144/SunNS/AppletTest/TaskT2.htm has only one applet
        embedded.

        http://216.147.49.144/SunNS/AppletTest/TaskT3.htm is using embed tags copied
        from Chapter.htm.

        I've attached them also.

        I've tried them both and Netscape still hangs.

        ---

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                stanleyh Stanley Ho (Inactive)
                Reporter:
                cprasadsunw Ck Prasad (Inactive)
                Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: