Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4393930

Default for -target should be 1.2 in Merlin

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Closed
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 1.3.0, 1.4.0
    • Fix Version/s: 1.4.0
    • Component/s: tools
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      beta
    • CPU:
      generic
    • OS:
      generic, solaris_7
    • Verification:
      Verified

      Description

      The default for the -target flag in Merlin should be 1.2. That generates
      bytecodes more in compliance with the JLS2.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              gafter Neal Gafter
              Reporter:
              gafter Neal Gafter
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Imported:
                Indexed: