Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4402447

HotSpot Server VM 2.0 doesn't detect installed JRE 1.2.2

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: 2.0, 1.2.2
    • Fix Version/s: 1.2.2_008
    • Component/s: deploy
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      008
    • CPU:
      x86
    • OS:
      windows_98, windows_nt
    • Verification:
      Verified

      Backports

        Description



        Name: yyT116575 Date: 01/05/2001


        java version "1.2.2"
        Classic VM (build JDK-1.2.2_007, native threads, symcjit)


        HotSpot Server VM will not install because it says that there is no appropriate
        JDK or JRE installed, and suggest me to install JDK or JRE 1.2.2 or 1.3
        although JRE 1.2.2 is installed. Same is happening when I install JDK 1.3, on
        Windows 2000, Windows 2000 AS and Windows 98
        (Review ID: 114642)
        ======================================================================

        Name: yyT116575 Date: 01/08/2001


        java version "1.3.0_01"
        Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.0_01)
        Java HotSpot(TM) Client VM (build 1.3.0_01, mixed mode)

        Steps to reproduce:
        - Download j2re-1_3_0_01-win.exe, and install on NT 4.0.
        - Download hotspot-2_0-win.exe, and run it.
        - Choose to update the Java 2 Runtime Environment.

        Text of error:

        Warning
          The installer was unable to locate an acceptable
        ! version of the JRE installed on the system.
          Please install either a 1.2.2 or 1.3 version of the JRE
          and then install the Java HotSpot Server VM.
               [OK]

        - Click OK and the installer quits [not really a Warning!]
        (Review ID: 114676)
        ======================================================================

        Name: rmT116609 Date: 01/16/2001


        java version "1.3.0_01"
        Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.0_01)
        Java HotSpot(TM) Client VM (build 1.3.0_01, mixed mode)

        install jdk or jre 1.3.0_01
        launch hotspot-2_0-win.exe
        error out stating it can't find a version of jdk/jre installed on system.

        note: works with jdk or jre 1.3.0
        (Review ID: 115264)
        ======================================================================

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                xjiangsunw Xuyang Jiang (Inactive)
                Reporter:
                yyoungsunw Yung-ching Young (Inactive)
                Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: