Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4419263

JSSE should support Plugin strong-crypto dynamic installation

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 1.4.0
    • Fix Version/s: 1.0.3
    • Component/s: security-libs
    • Labels:
      None
    • Subcomponent:
    • Resolved In Build:
      1.0.3
    • CPU:
      generic
    • OS:
      generic

      Description

      Plugin has mechanism to dynamically install extensions for applet.
      However, for this mechanism to work, the extension has to have at least some VERSION information and also provide installer if more sophiscated installation is needed. Currently, JSSE is distributed with JDK. However, due to import restriction imposed by different countries, only the weak-crypto version of JSSE is included in JDK. For applets which require strong crypto, plugin need to download strong crypto JSSE at runtime.
      In order for plugin to retrieve strong crypto JSSE, JSSE needs to provide its own installer for this purpose as well as provide version info for Plugin.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              wetmore Bradford Wetmore
              Reporter:
              jhangalsunw Jayalaxmi Hangal (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Imported:
                Indexed: