Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4429852

Crash in NetBeans when initializing app

    Details

    • Subcomponent:
    • CPU:
      x86
    • OS:
      linux

      Description

      I'm filing this bug report in response to correspondence with a user
      who has been working with us on some unrelated issues with Ladybird.

      I'm not sure of the cause of the crash. We have had a couple of reports
      of crashes on startup from CAP members, so I am giving this a high priority.
      The fact that he saw occasional crashes with Blackdown's 1.3 is not
      necessarily reason to disregard this report; the crash he reports below
      was seen with Sun's JDK1.3.1-beta.

      Here is the correspondence (see Comments for entire email with headers):

      ============================================================================

      But now, I gave the Beta a test. As before, I have done that on the same
      machine as last year, when I sent the bug-report (PIII, 550 MHz, 128 MB),
      and OS (SuSE Linux 6.3; Kernel 2.2.13), AND A GERMAN KEYBOARD.

      I have installed the Beta and set JAVA_HOME accordingly. Since last year
      the problem showed up when I tried to use forte4j, I have used that test
      again. As a result, I can tell you that most, but not all of the problems
      seem to be fixed. But let me tell you step by step:

      * I called the forty4j start-up script, which is appended as attachment 1
      * at first, the start-up seemd to be OK, but then, at some time during
        loading of modules, the app crashed; it produced a lot of output on
        stdout/stderr; I append the important parts of that output as attachment
        2, with some comments interlaced (<<< ... >>>); I hope, you can get
        the essentials
      * without change, I tried to start forte4j again, this time re-directing
        stdout to a file; I append that file as attachment 3; this time, f4j
        started correctly, but with two warnings on stderr; I append those
        together with an info message on stderr as attachment 4
      * within f4j, I seemingly could enter ALL of the special chars, which
        I couldn't last year, e.g., {}[]~@
      * executing the test program with those chars entered to a string,
        yielded again one error message, together with the expected output
        string; I append the source-code of that test program as attachment 5,
        and the program's output as attachment 6

      I hope, that report will help you, to track down the remaining problem
      with respect to my bug-report.

      In my oppinion, the crash during the first start-up was some problem with
      thread synchronization on my linux machine, but I'm not sure, what caused
      that problem. Every once and again, I have such a crash with the blackdown
      1.3 version, I use since last year. But that are rearly very sparse
      occasions, in the order of three or four all in all during 6 month or so
      of daily work with the jdk. Very good work, I must say. Work done by you
      and the guys from blackdown!

      Filed by ###@###.### on March 24, 2001.

        Attachments

          Activity

            People

            • Assignee:
              sgoldman Steve Goldman (Inactive)
              Reporter:
              ehawkessunw Eric Hawkes (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported:
                Indexed: