Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4453472

keyboard input blocked in SMC

    Details

    • Subcomponent:
    • Resolved In Build:
      beta2
    • CPU:
      generic, sparc
    • OS:
      solaris_8, solaris_9
    • Verification:
      Verified

      Description

      Effective with Java 1.4.0-beta-b61, SMC is exhibitting the following problems
      that did not occur with 1.4.0-beta-b59 or 1.3.1-beta-b15.

      These can be seen by running one of the following environments:

        - You must be running build37. SMC will be b55-built bytecodes
          running on a b61 JVM.

        - You can run an earlier OS build as long as you have b61 installed
          as the default JVM, and install the AI nightly build referenced
          at http://smpt.east/projects/SMC/install.html. Follow the
          "Cluster install" instructions. You should run "nuke_admin"
          first to purge any previous versions. Again, SMC will be b55-built
          bytecodes running on a b61 JVM.

        - b61-built bytecodes for SMC can be found at /net/divet.east/files/s81/b61-pkgs.
          Simply follow the same instructions as mentioned at the above URL, accept
          cd to this directory before running "install_admin".

      After installation, set JAVA_HOME to point to the location of B61 and
      run "/usr/sadm/bin/smc". When the console comes up, note the following
      problems:

      1) The border around work-in-progress icon in the upper-right corner is now
         too big. Note the gap along the top and bottom of the image. This
         did not happen before.

      2) Invoke Console->Preferences. Note the grey square in the top-left
         corner of the dialog. This is supposed to be a question mark image
         and has always shown before.

      3) Invoke Console->Preferences. Click on the Fonts tab. Click on any
         of the "Change..." buttons. Click on the Color button. Select a color.
         Click Ok, click Ok, click Ok. Now go to any dialog that requires text
         input and note that keyboard input is blocked. There doesn't appear
         to be any way to get it unblocked other than by restarting the console.
         
         The quickest way to a dialog might be to click on the "Devices and Hardware"
         turner in the left-side navigation pane, then click on "Serial Ports".
         Log in, and after the list of ports is displayed, select one and invoke
         Actions->Properties.

      4) In step 3) above, when you click on "Serial Ports" (or any tool in the
         navigation pane), you will be prompted with a login dialog upon the
         1st tool selection. When you type your password fast, the character
         mask does not seem to keep up. That is, my password has 6 characters,
         yet when I type it fast, I only see the '#' mask character echoed
         twice. Note that this does not interfere with authentication, which
         does succeed, but the character mask behavior is different than previously.

      5) In step 3) above, when you click on "Serial Ports", the right-side pane
         says "Loading Serial Ports Tool", followed by "Loading Serial Ports".
         Both text messages are supposed to be displayed in the same purple color
         as the icon image to the immediate left. However, in b61, they appear
         in the color black.

      6) In step 3) above, note also how the main window completely fills in
         with grey and then repaints itself before the dialog comes up - this too,
         is new behavior which has not been seen previously. This does NOT happen
         if you double-click on the object to invoke properties, as opposed to
         the Actions->Properties menu item.

      7) Difficult to reproduce, but sometimes objects displayed in the right-side
         pane are invisible. A subsequent refresh makes them visible.

      8) For any tool which displays it's main object list as large icons (say,
         System Configuration->Users->Users from the navigation pane), try resizing
         the console window just enough so that you fill up an entire row. Then
         right-click thr right-most object and select "Properties". When the
         dialog comes up, note how keyboard input is blocked on any text field.
         Unlike in step 3) however, it doesn't appear to remain blocked, as
         dismissing the dialog and invoking some other dialog with a textfield
         seems to work fine.

      I don't know if these are all manifestations of the same bug. But I'm
      including them in one bug report because they all seem to be related to
      something gone awry relative to processing the AWT event queue, and perhaps
      a pattern can be easily seen if they're all listed together.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                dmendenhsunw David Mendenhall (Inactive)
                Reporter:
                duke J. Duke (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: