Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4471583

unable to pass JCK tests in singleJVM mode

    Details

    • Subcomponent:
    • CPU:
      generic
    • OS:
      generic

      Description



      Name: poR10007 Date: 06/19/2001



      Java VM from jdk1.4.0beta fails to pass JCK-runtime tests in singleJVM mode.
      During the build of NSK part of JCK testsuite starting from some point tests
      fail with java.lang.OutOfMemoryError. Sometimes the Javatest agent crashes
      dumping core and producing the following error message:

      Unexpected Signal : 11 occurred at PC=0xFE5941F4
      Function=JVM_NewInstanceFromConstructor+0x47E4
      Library=/export/ld54/java/dest/jdk1.4.0beta-b65/solsparc/jre/lib/sparc/client/libjvm.so


      Dynamic libraries:
      0x10000 /export/ld25/java/dest/jdk1.4.0beta-b65/solsparc/bin/../bin/sparc/native_threads/java
      0xff360000 /usr/lib/libthread.so.1
      0xff3a0000 /usr/lib/libdl.so.1
      0xff280000 /usr/lib/libc.so.1
      0xff260000 /usr/platform/SUNW,Ultra-Enterprise/lib/libc_psr.so.1
      0xfe400000 /export/ld54/java/dest/jdk1.4.0beta-b65/solsparc/jre/lib/sparc/client/libjvm.so
      0xff210000 /usr/lib/libCrun.so.1
      0xff1f0000 /usr/lib/libsocket.so.1
      0xff100000 /usr/lib/libnsl.so.1
      0xff1c0000 /opt/SUNWspro/lib/libm.so.1
      0xff240000 /usr/lib/libw.so.1
      0xff0e0000 /usr/lib/libmp.so.2
      0xff0a0000 /export/ld54/java/dest/jdk1.4.0beta-b65/solsparc/jre/lib/sparc/native_threads/libhpi.so
      0xff070000 /export/ld54/java/dest/jdk1.4.0beta-b65/solsparc/jre/lib/sparc/libverify.so
      0xff030000 /export/ld54/java/dest/jdk1.4.0beta-b65/solsparc/jre/lib/sparc/libjava.so
      0xfe7e0000 /export/ld54/java/dest/jdk1.4.0beta-b65/solsparc/jre/lib/sparc/libzip.so
      0xfc960000 /export/ld54/java/dest/jdk1.4.0beta-b65/solsparc/jre/lib/sparc/libnio.so
      0xfc940000 /usr/lib/libposix4.so.1
      0xfc910000 /export/ld25/java/dest/jdk1.4.0beta-b65/solsparc/bin/../jre/lib/sparc/libnet.so
      0xfc860000 /usr/lib/libaio.so.1
      0xfc840000 /usr/lib/nss_nisplus.so.1
      0xfc810000 /usr/lib/libdoor.so.1
      0xf3a00000 /export/ld51/java/pas/build/JCK-runtime-b65-cf-2/unzip/JCK-runtime-14/lib/libjckjni.so
      0xfa7b0000 /export/ld51/java/pas/build/JCK-runtime-b65-cf-2/unzip/JCK-runtime-14/lib/libjckatr.so
      0xfa480000 /export/ld54/java/dest/jdk1.4.0beta-b65/solsparc/jre/lib/sparc/libawt.so
      0xf3880000 /export/ld25/java/dest/jdk1.4.0beta-b65/solsparc/bin/../jre/lib/sparc/libmlib_image.so
      0xfa410000 /export/ld54/java/dest/jdk1.4.0beta-b65/solsparc/jre/lib/sparc/motif21/libmawt.so
      0xf2880000 /usr/lib/libXm.so.4
      0xf3290000 /usr/openwin/lib/libXt.so.4
      0xfa590000 /usr/openwin/lib/libXext.so.0
      0xf43e0000 /usr/openwin/lib/libXtst.so.1
      0xf3000000 /usr/openwin/lib/libX11.so.4
      0xf42a0000 /usr/openwin/lib/libdps.so.5
      0xf43c0000 /usr/openwin/lib/libSM.so.6
      0xf4390000 /usr/openwin/lib/libICE.so.6
      0xf3fb0000 /export/ld54/java/dest/jdk1.4.0beta-b65/solsparc/jre/lib/sparc/libcmm.so
      0xf3eb0000 /export/ld54/java/dest/jdk1.4.0beta-b65/solsparc/jre/lib/sparc/libjpeg.so

      Local Time = Fri Jun 15 04:56:53 2001
      Elapsed Time = 3560
      #
      # HotSpot Virtual Machine Error : 11
      # Error ID : 4F530E43505002D7 01
      # Please report this error at
      # http://java.sun.com/cgi-bin/bugreport.cgi
      #
      # Java VM: Java HotSpot(TM) Client VM (1.4.0-beta-b65 mixed mode)
      #

      OutOfMemory failure is quite reproducible, crash of Hotspot is intermittent.
      The failure was reproduced on jdk1.4.0beta-b58, b64, b65, b68, on both
      Solaris 7 and Solaris 8.

      We tested the following modes attempting to find a cause of the
      failure (all these configurations didn't pass testing either):

      1. java -ms32m -mx64m -Xfuture (default build mode)
      2. java -ms32m -mx512m -Xfuture
      3. java -ms32m -mx64m -Xfuture -Xconcgc
      4. using -loaddir parameter in Javatest environment to force
         the agent to load classes for each test with its own
         new classloader
      5. using logging of gc activity (-Xloggc option). The last lines
         of the log before the agent has died were the following:
         
         3257.27: [Full GC 20541K->14155K(34736K), 1.2465899 secs]
         3258.52: [Full GC 14155K->12914K(34736K), 1.1989310 secs]
         3262.3: [Full GC 14166K->13055K(34736K), 1.1658022 secs]
         3263.57: [Full GC 13098K->13065K(34736K), 1.1147656 secs]
         3264.75: [Full GC
         
      6. using nonconcurrent mode of the agent for testing (default
         concurrency factor in the build is 2, i.e. the agent
         runs two tests in a time)
         
      Our test suite consists of about 7300 tests (lang, vm and some
      of API tests). We also tried to divide the whole testsuite
      into parts and run them separately. Lang and vm tests (5570 tests)
      pass when runnning without API tests. API tests pass running
      separately too.

      To reproduce the bug do the following:
      1. cd into directory where the report and work directories will be created
      2. run script /net/sqeel.eng/export/disk04/dev02/users/NSKrotator/JCK-merlin-runtime/start
      You can contact our JCK rotator (###@###.###) if you have
      any questions on reproducing this bug.

      ======================================================================
       ###@###.### 07.17.2001

      We created a little program to run tests from a big testlist within
      the same JVM in a loop without using a JavaTest agent. We reproduced
      this bug with the program on jdk1.4.0beta-b70 - VM hangs after
      OutOfMemoryError. We also tried to run it with -Xss2m and using java_g
      - VM crashes producing core dump or hangs after OutOfMemoryError too.

      You can use the program by running the following script:
      /net/sqeel.eng/export/disk04/dev02/users/NSKrotator/JCK-merlin-runtime/sameJVM.run

      If you meet a program failure due to a security exception please
      create .java.policy file in your home directory with the following contents:

      grant{
          permission java.security.AllPermission ;
      };

      ==============================================================================
      Pavel Ozhdikhin ###@###.### 2001-07-24

      Now the problem is reduced to OutOfMemory errors only. The crash
      we observed before was caused by absence of needed patch on our
      Solaris 5.7 machine. Sorry for confusion. The words of evaluation
      of 2001-06-27 saying "Do not pay attention to OutOfMemory" are
      incorrect. Now the only problem preventing JCK to be passed in
      singleJVM mode is JVM hang immediately after OutOfMemory error.

        Attachments

          Activity

            People

            • Assignee:
              dmcox David Cox
              Reporter:
              passunw Pas Pas (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported:
                Indexed: