Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4518583

JRE 1.4 beta3 should have a better way to register the plugins file

    XMLWordPrintable

    Details

    • Subcomponent:
    • Resolved In Build:
      rc1
    • CPU:
      x86
    • OS:
      windows_98, windows_2000, windows_xp
    • Verification:
      Verified

      Description

      Tested OS : Winodws2000, Windosws98, WindowsNT SP6 and WindowsXP rci japanese.
      Tested build : b83 j2re-1_4_0-beta3-bin-b83-win-i-11_oct_2001.exe
                     b84 j2re-1_4_0-beta3-bin-b84-win-i-20_oct_2001.exe
                         j2re-1_4_0-beta3-bin-b84-win-20_oct_2001.exe
                         j2sdk-1_4_0-beta3-bin-b84-win-20_oct_2001.exe

      I found that the number of installed dll file is different between b81 and b83.

      NPJava11.dll, NPJava12.dll, NPJava32.dll and NPJP140.dll file, they are not installed under Netscape6\Plugins directry using J2SDK/J2RE installer for windows.

      After installing j2sdk/j2re b83 and b84:
      \Program Files\Netscape\Netscape6\Plugins\npoji610.dll

      After installing j2sdk/j2re b81:
      \Program Files\Netscape\Netscape6\Plugins\npoji610.dll
                                               \NPJava11.dll
                                               \NPJava12.dll
                                               \NPJava32.dll
                                               \NPJPI140.dll

      Some NPxxxx.dll files are not installed properly under Netscape6's plugins directry.

      Lacking NPxxxx.dll files on Netscape6's plugin directry are installed correctry under other Netscape's plugin directry (ex.Netscape comunicator4.7).

      After installing b84, Communicator4.7's plugins directry :
      \Proguram Files\Netscape\Communicator4.7\Program\Plugins\npoji610.dll
                                                              \NPJava11.dll
                                                              \NPJava12.dll
                                                              \NPJava32.dll
                                                              \NPJPI140.dll

      Lacking NPxxxx.dll files(NPJava11.dll, NPJava12.dll, NPJava32.dll, NPJPI140.dll) needs to be installed under Netscap6's plugin directry.


      * NOTE *
        This problem was described in #4514617.
        However, as this problem is not original problem of #4514617,
        I filed this as a separate bug.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              xlu Xiaobin Lu (Inactive)
              Reporter:
              rsuzukisunw Rieko Suzuki (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Imported:
                Indexed: