Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4559024

networking classes might be having problems.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3
    • Resolution: Duplicate
    • Affects Version/s: 1.0
    • Fix Version/s: None
    • Component/s: core-libs
    • Subcomponent:
    • CPU:
      generic
    • OS:
      solaris_8

      Description

      [Fri Dec 7 12:53:52 PST 2001] - rambo

      Let me state up front, I'm not exactly sure about the cat/subcat.
      Bugtraq does not the the correct Release fields, so I just said 1.0
      The OS is correct.

      We needed a pure ftp proxy program for some in-house testing, and I
      found a java one on the web. FtpProxy, source is in the attachements.

      We were using it to test installation, and when it got to the end of
      of the installation, it started acting strangely, and seemed to me like it was
      forking off more threads than it should have been. This was on a Sun4u
      (ultra 60), running s9_b51, using /bin/java, which was version 1.4.0-rc.

      I then ran the same class files it on an s28s_u3wos_08, using /bin/java version 1.2.2, and it worked flawlessly.

      I then tested various jre's on both the s9b51 and s28 system, and it never
      worked correctly on the s9b51 system, but always worked on the s28 system.
      So, it might not actually be the jvm that is screwing up, but something in the OS.

      I modified the source to the FtpProxy just to turn on debugging information.
      A good run of the FtpProxy debug output on the s8u3 machine is attached as
      ftp.good, the log of the bad run, on the s9b51 machine is ftp.bad.

      I've duplicated similar errors by using ftp directly, and here's how
      to set it up:

      1. get the source for Ftpproxy from the attachements, and compile it
      using javac FtpProxy

      2. run it on the proxy server as:
      java FtpProxy [port]
      (default port is 8089)

      3. run ftp on the source machine as such:

      my parameters:
      source host : war
      dest host : ins3525-svr
      dest login : root
      proxy host : ins1455-svr
      proxy port : 8089

      war> ftp
      ftp> open ins1455-svr 8089
      Connected to ins1455-svr.eng.sun.com.
      220 Java FTP Proxy Server (usage: USERID=user@site) ready.
      Name (ins1455-svr:rambo): root@ins3525-svr
      331 Password required for root.
      Password:
      230 User root logged in.
      Remote system type is UNIX.
      Using binary mode to transfer files.

      < now we are ftp'ed into ins3525-svr >


      The ftp good and bad logs (attached) show the output of the
      FtpProxy debugging statements to show what strangeness is going on.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              jccollet Jean-Christophe Collet (Inactive)
              Reporter:
              duke J. Duke (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Imported:
                Indexed: