Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4621336

Collision detection popup message not shown for Multi-Version support on windows

    XMLWordPrintable

    Details

    • Subcomponent:
    • CPU:
      x86
    • OS:
      generic

      Description

      When Mutliple JRE 's installed on the system and if an applet is run specifying the particular version of Plug-in (Unique CLSID and MIME type) the collision detection message dialog is not shown but shows "Fatal Error" message.

      When an applet is running in a browser with Plug-in version 1.3.1 (1.3.1 CLSID and 1.3.1 MIME type) and tried to run another applet with Plug-in 1.4.0(1.4.0 CLS ID and MIME type) in the same session of the browser , the collision detection message dialog from Plug-in doesnot popup to warn the user about the collision saying another version of VM is already running attached to the browser process.

      To reproduce the problem :

      1. Install ladybird (JRE 1.3.1.)
      2. Install Merlin build 90/91
      3. Bring up the browser and load the following applet

      http://sqesvr/deployment2/sridhare/ws-07-2000/tests/multiversion/1.3.1/BAT/Test_131.html

      4. Verify that the applet is running using Plug-in 1.3.1
      5. Load the following applet into the same browser session in which 1.3.1 applet is already running.

      http://webwork.sfbay/products/plugin/1.4/demos/applets/Clock/example1.html

      6. You will notice "Fatal Error" message , Plug-in should pop up waring collision detection message instead with appropriate message to user.

        Attachments

          Activity

            People

            Assignee:
            zgu Zhengyu Gu
            Reporter:
            senugulaorcl Sridhar Enugula (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: