Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4713761

Solaris Web Start in Solaris 10 can't display Japanese using Hopper runtime pkg

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1
    • Resolution: Fixed
    • Affects Version/s: solaris_10
    • Fix Version/s: 1.4.1
    • Component/s: client-libs
    • Labels:
    • Subcomponent:
      2d
    • Resolved In Build:
      rc
    • CPU:
      sparc
    • OS:
      solaris_10
    • Verification:
      Verified

      Description

      Japanese characters are displayed as square boxes if Hopper SUNWj3rt Runtime packagesis added to the miniroot of Solaris 10 b13 image. Hopper b09 is the first build this problem occurs, and b10 through b16 all have this problem. Hopper b08 works fine. All 3 Japanese fonts failed to display while Korean and Chinese fonts displayed OK.

      Steps to reproduce:
      - Install Hopper SUNWj3rt pkg on /export/s10/solarisdvd.s10s_dvd/latest/Solaris_10/Tools/Boot of installer
      - use addclient to add test system
      - drop test system to prom
      - boot net from test system
      - Choose Japanese and any of the 3 Japanese fonts
      - Solaris Web Start will come up and Japanese chars are displayed as boxes.

        Attachments

          Activity

            People

            Assignee:
            prr Philip Race
            Reporter:
            jaleesunw James Lee (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: