Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4726318

REGRESSION: can't type in plugin login dialog

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3
    • Resolution: Duplicate
    • Affects Version/s: 1.4.1
    • Fix Version/s: None
    • Component/s: deploy
    • Labels:
    • Subcomponent:
    • CPU:
      x86
    • OS:
      windows_2000

      Description



      Name: gm110360 Date: 08/05/2002


      FULL PRODUCT VERSION :
      java version "1.4.1-beta"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.1-beta-b14)
      Java HotSpot(TM) Client VM (build 1.4.1-beta-b14, mixed mode)

      FULL OPERATING SYSTEM VERSION :
      Microsoft Windows 2000 [Version 5.00.2195]

      A DESCRIPTION OF THE PROBLEM :
      We have an apache web server using server authentication
      via .htaccess/.htpassword. We typically see two password
      dialogs when accessing the site, one presented by the
      browser and another by the Java plug-in. With JRE1.4.0_01
      this works fine. After upgrading to JRE1.4.1beta, when the
      second password dialog is displayed the cursor is in the
      username field but typing with the keyboard displays no
      characters. It is as if the text field doesn't have
      keyboard focus. Left-clicking in the dialog doesn't help.

      If you cover the browser and password dialog window with
      another application (via alt-tab), and then uncover it, and
      left-click in the dialog, then it is possible to enter
      characters in the text field normally.

      REGRESSION. Last worked in version 1.4

      STEPS TO FOLLOW TO REPRODUCE THE PROBLEM :
      1. Access a web page with a Java Plug-in-based unsigned
      applet using server authentication.
      2. Browser displays password dialog. Enter username and
      password.
      3. Plug-in displays password dialog. Can't type in login
      username text field.

      REPRODUCIBILITY :
      This bug can be reproduced always.

      CUSTOMER WORKAROUND :
      Use JRE1.4.0_01 plug-in. However, this version has
      graphics problems on Windows NT that are fixed in 1.4.1, so
      we can't use it in our production s/w. This means we are
      stuck with JRE1.3.1_xx until 1.4.1 works.

      Release Regression From : 1.4.0_01
      The above release value was the last known release where this
      bug was known to work. Since then there has been a regression.

      (Review ID: 160355)
      ======================================================================

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              dgu Dennis Gu (Inactive)
              Reporter:
              gmanwanisunw Girish Manwani (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Imported:
                Indexed: