Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4753265

[1.4.0_02] Crash in 64 bit HotSpot Server JVM,, backport 4746263

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: 1.4.0_03
    • Fix Version/s: 1.4.0_04
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      04
    • CPU:
      sparc
    • OS:
      solaris_8

      Description

      Customer is trying to benchmark their application using J2SE1.4 64 bit on
      E4500 and E10K systems, but are running into crashes. They have
      tried with 1.4.0_02, early access 1.4.0_03 and 1.4.1 64bit
      versions and the problem occurs in all with the server HotSpot
      compiler. They have tried with 1.4.0_2 -client using the
      32bit binary and the crashes don't occur, but the performance is
      only 40% of what -server 64bit can provide.

      The first crash message is seen consistently using 64-Bit Server VM
      1.4.0_03-ea-b01. The cust tested with a 64bit fastdebug build of 1.4.0_03
      and assert failures occurred assert(top <= end, "pointers out of order")
      The stack trace is located in the attachments and the actual core files can
      be provided upon requested.

      Unexpected Signal : 10 occurred at PC=0xFFFFFFFF39A3001C
      Function=printString (compiled Java code)
      Library=(N/A)

      Current Java thread:

      Dynamic libraries:
      0x100000000 /c1t1/tal/jre/14003/bin/sparcv9/java
      0xffffffff7f300000 /usr/lib/64/libthread.so.1
      0xffffffff7f500000 /usr/lib/64/libdl.so.1
      0xffffffff7ef00000 /usr/lib/64/libc.so.1
      0xffffffff7ee00000 /usr/platform/SUNW,Ultra-Enterprise-10000/lib/sparcv9/libc_psr.so.1
      0xffffffff7d000000 /c1t1/tal/jre/14003/lib/sparcv9/server/libjvm.so
      0xffffffff7ce00000 /usr/lib/64/libCrun.so.1
      0xffffffff7cc00000 /usr/lib/64/libsocket.so.1
      0xffffffff7ca00000 /usr/lib/64/libnsl.so.1
      0xffffffff7c800000 /usr/lib/64/libm.so.1
      0xffffffff7db00000 /usr/lib/64/libw.so.1
      0xffffffff7c500000 /usr/lib/64/libmp.so.2
      0xffffffff7c200000 /c1t1/tal/jre/14003/lib/sparcv9/native_threads/libhpi.so
      0xffffffff7c000000 /c1t1/tal/jre/14003/lib/sparcv9/libverify.so
      0xffffffff7be00000 /c1t1/tal/jre/14003/lib/sparcv9/libjava.so
      0xffffffff7bb00000 /c1t1/tal/jre/14003/lib/sparcv9/libzip.so
      0xfffffffee3700000 /usr/lib/locale/en_US.ISO8859-1/sparcv9/en_US.ISO8859-1.so.2
      0xfffffffee1a00000 /t3-6/gatherer/g20/Shared/libxacct_native_sparcv9_SunOS.so
      0xfffffffee1800000 /c1t1/tal/jre/14003/lib/sparcv9/libnet.so
      0xfffffffee0400000 /t3-6/gatherer/g20/Shared/libdb_java-3.3-sparcv9-SunOS.so
      0xfffffffedf400000 /c1t1/tal/jre/14003/lib/sparcv9/libawt.so
      0xfffffffedf200000 /c1t1/tal/jre/14003/lib/sparcv9/libmlib_image.so
      0xfffffffedf000000 /c1t1/tal/jre/14003/lib/sparcv9/motif21/libmawt.so
      0xfffffffedeb00000 /usr/dt/lib/sparcv9/libXm.so.4
      0xfffffffede900000 /usr/openwin/lib/sparcv9/libXt.so.4
      0xfffffffede700000 /usr/openwin/lib/sparcv9/libXext.so.0
      0xfffffffede500000 /usr/openwin/lib/sparcv9/libXtst.so.1
      0xfffffffede200000 /usr/openwin/lib/sparcv9/libX11.so.4
      0xfffffffede000000 /usr/openwin/lib/sparcv9/libdps.so.5
      0xfffffffedde00000 /usr/openwin/lib/sparcv9/libSM.so.6
      0xfffffffeddb00000 /usr/openwin/lib/sparcv9/libICE.so.6
      0xfffffffedd900000 /usr/openwin/lib/sparcv9/libdga.so.1

      Local Time = Wed Sep 18 00:34:50 2002
      Elapsed Time = 577
      #
      # HotSpot Virtual Machine Error : 10
      # Error ID : 4F530E43505002D5 01
      # Please report this error at
      # http://java.sun.com/cgi-bin/bugreport.cgi
      #
      # Java VM: Java HotSpot(TM) 64-Bit Server VM (1.4.0_03-ea-b01 mixed mode)
      #
      # An error report file has been saved as hs_err_pid22037.log.
      # Please refer to the file for further information.
      #

      #
      # HotSpot Virtual Machine Error, assertion failure
      # Please report this error at
      # http://java.sun.com/cgi-bin/bugreport.cgi
      #
      # Java VM: Java HotSpot(TM) 64-Bit Server VM (1.4.0_03-internal-20020821-debug mixed mode)
      #
      # assert(top <= end, "pointers out of order")
      #
      # Error ID: /net/jdk/export/jpse01/hshen/J2SE/140/hotspot/src/share/vm/memory/collectedHeap.inline.hpp, 121 [ Patched ]
      #
      # Problematic Thread: prio=5 tid=0x10573c2b8 nid=0x5c runnable
      #
      Dumping core....

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                chrisphi Chris Phillips
                Reporter:
                atongschsunw Albert Tong-schmidt (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: