Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4798859

Deadlock situation introduced in Java Code (1.4.2)

    Details

      Description

      BAT_Suite BeanCounter was not working for jdk1.3.1_07. It's just hang right after you click the "Start" button. The only thing you can do is cancel the process by entering "Control+ C" buttons. However, I tried on jdk1.3.1_05 and jdk1.3.1_06 they all working fine and produce the results.

      How to reproduce:
      Machine Name: jtest-s14
      Remote login to jtest-s14.sfbay

      cd to this directory.
      /export/updates/1.3.1_07/BAT_Suite/BAT_Suite/BeanCounter

      set the environment for JAVA_HOME

      To run the test use this command.

      sh runnit.sh

      There will be a GUI pop up you will hit the "Start" button to run the test. The progress bar was show 1% completion and the test was hang at that point.

      For jdk1.3.1_05 and jdk1.3.1_06 the test was running at 100% completion.

      -----------------

      When ran the tests for 1.3.1_07 with command $sh runnit.sh runauto/run
      I got the following exception.

      java.lang.NoSuchMethodError
              at Reporter.endDocument(Reporter.java:302)
              at BeanCounter.testListeners(BeanCounter.java:485)
              at BeanCounter.test0Listeners(BeanCounter.java:243)
              at BeanCounter.testComponents(BeanCounter.java:216)
              at BeanCounter.run(BeanCounter.java:186)
              at java.lang.Thread.run(Thread.java:479)

      It is finishing tests for java.awt.Container (which is probably 1% of tests) after that it is not able to update/create the log files. This could be because one or more methods in 1.3.1_05 have been removed/changed in 1.3.1_07.

      In the same way I tried this test for 1.4.1 releases also(same workspace). It is failing on 1.4.1fcs and 1.4.1 other releases also with the following error.

      Jan 6, 2003 5:58:05 PM java.util.prefs.FileSystemPreferences checkLockFile0ErrorCode
      WARNING: Could not lock System prefs.Unix error code 0.
      Jan 6, 2003 5:58:05 PM java.util.prefs.FileSystemPreferences syncWorld
      WARNING: Couldn't flush system prefs: java.util.prefs.BackingStoreException: Couldn't get file lock.

      But it ran fine with the following 1.4.1 beta release.

      java version "1.4.1-beta"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.1-beta-b03)
      Java HotSpot(TM) Client VM (build 1.4.1-beta-b03, mixed mode)

      Bhoopal.



      ###@###.### 2003-01-06

        Attachments

          Activity

            People

            • Assignee:
              shickeysunw Shannon Hickey (Inactive)
              Reporter:
              duke J. Duke (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported:
                Indexed: