Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4870461

1.3.1 java plugin support for new mime-type plugin tests *NOT A REGRESSION*

    XMLWordPrintable

    Details

    • Subcomponent:
    • CPU:
      x86
    • OS:
      windows_nt

      Description

      1.3.1_09 Install Test *This is NOT A REGRESSION*

      Tested on Win NT / Win XP Pro

      Steps to reproduce:

      1. Ensuring system is clean
          Install 1.3.1_09b01 JDK or JRE to default install directory.
          
          Go to Start>Settings>Control Panel
          
          Choose the 131_09 Java Plugin
          
          On the Basic Tab ->
          Check "Show Java Console">Apply
          
      2. Having no browser windows already open, Open a new Netscape Browser (any version will do)
          - Go to Help>About Plug-ins
        
      3. View Java Plugin Support for netscape.

      of the type
      application/x-java-applet;version=1.2.2

      Support for 1.3.1 is *Missing*
      application/x-java-applet;version=1.3.1

      Specific 1.3.1 version support is provided
      application/x-java-applet;jpi-version=1.3.1_09


      4. Go to the new MimeType tests at
      ============================================================================
      http://sqesvr.sfbay.sun.com/deployment1/ws_plugin/doc/proc/JPI_bat.html
      ============================================================================
      Try 1.3.1 Demo link (ofcourse 1.4+ aren't expected to run and do not)

      This fails to load in Netscape, but does in Internet Explorer.
      (Strangely, the 1.4 and 1.4.1 Demo applets also load in Internet Explorer and PASSES
      can be seen in 1.3.1_09 Java Console)

      Viewing the html source code sees

      <embed type="application/x-java-applet;version=1.3.1" TESTNAME="MimeType_131"
       ...
       ...

      so it seems it's looking for 1.3.1 java version.


      The following applet does load with 1.3.1_09
      ============================================================================
      http://java.sun.com/products/plugin/1.3/demos/applets/Clock/example1.html
      ============================================================================

      Viewing the html source code sees

      <embed type="application/x-java-applet;jpi-version=1.3.1
      ...
      ...

      BugId #4483141 example description
      ==============
      The HTML for the specified applets require a particular version of
      the JRE to run. The version requested is 1.3.1...

      application/x-java-applet;jpi-version=1.3.1
                                ^^^^^^^^^^^^^^^^^
      For 1.3.1_01 to be used also, the mimetype would be specified as...

      application/x-java-applet;version=1.3.1

      ==============


      To me this means that the new 1.3.1 mime types applet should load with 1.3.1_09 ( http://sqesvr.sfbay.sun.com/deployment1/ws_plugin/doc/proc/JPI_bat.html )
      because the html for the specific applet is not requiring a particular version i.e. jpi-version=1.3.1

      That is, 1.3.1_09 belongs to the family of 1.3.1

      The second applet page should not have loaded in this case because it is requiring a particular version??

      Is this correct??

      Either way - I think it is expected behaviour that 1.3.1 support should show in Netscape About>Plugins
      (application/x-java-applet;version=1.3.1)



      **Note: Installing 1.4.1_01b01 JDK/JRE does show support for version 1.4.1 in About>Plugin-ins

      ###@###.### 2003-05-28

        Attachments

          Activity

            People

            Assignee:
            abhalesunw Ajit Bhale (Inactive)
            Reporter:
            duke J. Duke (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: