Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4882974

JVM generates duplicate warning lines

    Details

    • Subcomponent:
    • CPU:
      generic
    • OS:
      generic

      Description



      Name: dkR10031 Date: 06/24/2003



      Current linux and solaris implementations of the JVM
      generates duplicate warning lines in a case when it is
      called with the '-classic' flag. There is only one
      warning line for the windows JVM implementation.
      To reproduce this bug please execute java with
      the '-classic -version -Xrunjcov' options:
      ---------------- Test output for the linux -----------------------
      bash-2.03$ uname -a
      SunOS novo148 5.8 Generic_108528-20 sun4u sparc SUNW,Ultra-80
      bash-2.03$ /net/linux-15/export/home/java/jdk1.4.2/sparc/bin/java -classic -version -Xrunjcov:V
      Warning: classic VM not supported; client VM will be used
      Warning: classic VM not supported; client VM will be used
      java version "1.4.2"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2-b27)
      Java HotSpot(TM) Client VM (build 1.4.2-b27, mixed mode)
      ---------------- End of the linux test output --------------------------

      ======================================================================

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ksrini Kumar Srinivasan
                Reporter:
                dimasunw Dima Dima (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: