Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4889855

stddoclet: Doclet should warn when @deprecated is misused

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Not an Issue
    • Affects Version/s: 1.4.2
    • Fix Version/s: None
    • Component/s: tools
    • Labels:

      Description

      I don't believe that you can deprecate a package. If you put @deprecated in package.html, it has no affect on the source (i.e. the compiler will not warn about this deprecation). That means that we should not allow this tag to be used in package.html. To let users know that they are misusing the tag, print a warning.

        Attachments

          Activity

            People

            Assignee:
            bpatel Bhavesh Patel (Inactive)
            Reporter:
            jhosunw Jamie Ho (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: