Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4899908

Plugin does not download 1.4.2 as the "highest" JRE

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 1.4.2
    • Fix Version/s: 1.4.2
    • Component/s: deploy
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      1.4.2
    • CPU:
      x86
    • OS:
      windows_2000
    • Verification:
      Verified

      Description

      Name: gm110360 Date: 08/01/2003


      FULL PRODUCT VERSION :
      I used the HTML converter tool that came with the 1.4.2 SDK.

      FULL OS VERSION :
      Microsoft Windows 2000 [Version 5.00.2195]

      EXTRA RELEVANT SYSTEM CONFIGURATION :
      Running IE 6 [Version 6.0.2800.1106CO]

      A DESCRIPTION OF THE PROBLEM :
         I converted a webpage using the HTMLConverter tool that came with the 1.4.2 SDK whereby I specified that I wanted the page's applet to use any java 1.4 or higher.
        When I open the webpage on a system that does not have any java installed on it, I am prompted to download the installer for the java 1.4.1_03 JRE. Since 1.4.2 is the latest version (and there's a bug in 1.4.1_03 that breaks my applet), I was expecting the 1.4.2 JRE to be downloaded. Can you change you're download site to have the 1.4.2 JRE as the latest version?

      STEPS TO FOLLOW TO REPRODUCE THE PROBLEM :
      1. Create an applet and make a simple accompanying HTML page.
      2. Run the HTML page though the HTMLConverter tool and specify the following:
         Template File: "Extended (Standard + All Browsers/Platforms)"
         Java versioning for Applets: "Use any Java 1.4, or higher".
      3. Upload the applet and webpage to a web server.
      4. From a second machine, which does not have any java SDK or JRE installed, go
         to the site with the converted webpage.

      EXPECTED VERSUS ACTUAL BEHAVIOR :
      EXPECTED -
      A window should appear, asking if I'd like to install and run "Java Plug-in 1.4.2".
      ACTUAL -
      A window pops up asking if I'd like to install and run "Java Plug-in 1.4.1_03".

      ERROR MESSAGES/STACK TRACES THAT OCCUR :
      No error messages.

      REPRODUCIBILITY :
      This bug can be reproduced always.

      ---------- BEGIN SOURCE ----------
      Test applet's code:
      public class MyTestApplet extends java.applet.Applet
      {
          
          /** Initialization method that will be called after the applet is loaded
           * into the browser.
           */
          public void init()
          {
          }
          
      }

      The converted webpage:
      <HTML>
      <HEAD>
         <TITLE>Applet HTML Page</title>
      </head>
      <BODY>

      <H3><HR WIDTH="100%">Applet HTML Page<HR WIDTH="100%"></h3>

      <P>
      <!--"CONVERTED_APPLET"-->
      <!-- HTML CONVERTER -->
      <SCRIPT LANGUAGE="JavaScript"><!--
          var _info = navigator.userAgent;
          var _ns = false;
          var _ns6 = false;
          var _ie = (_info.indexOf("MSIE") > 0 && _info.indexOf("Win") > 0 && _info.indexOf("Windows 3.1") < 0);
      //--></script>
          <COMMENT>
              <SCRIPT LANGUAGE="JavaScript1.1"><!--
              var _ns = (navigator.appName.indexOf("Netscape") >= 0 && ((_info.indexOf("Win") > 0 && _info.indexOf("Win16") < 0 && java.lang.System.getProperty("os.version").indexOf("3.5") < 0) || (_info.indexOf("Sun") > 0) || (_info.indexOf("Linux") > 0) || (_info.indexOf("AIX") > 0) || (_info.indexOf("OS/2") > 0) || (_info.indexOf("IRIX") > 0)));
              var _ns6 = ((_ns == true) && (_info.indexOf("Mozilla/5") >= 0));
      //--></script>
          </COMMENT>

      <SCRIPT LANGUAGE="JavaScript"><!--
          if (_ie == true) document.writeln('<OBJECT classid="clsid:8AD9C840-044E-11D1-B3E9-00805F499D93" WIDTH = 350 HEIGHT = 200 codebase="http://java.sun.com/products/plugin/autodl/jinstall-1_4-windows-i586.cab#Version=1,4,0,0"><NOEMBED><XMP>');
          else if (_ns == true && _ns6 == false) document.writeln('<EMBED type="application/x-java-applet;version=1.4" CODE = "MyTestApplet.class" WIDTH = 350 HEIGHT = 200 scriptable=false pluginspage="http://java.sun.com/products/plugin/index.html#download"><NOEMBED><XMP>');
      //--></script>
      <APPLET CODE = "MyTestApplet.class" WIDTH = 350 HEIGHT = 200></xmp>
          <param>
          <param>
          <param>


      </applet>
      </noembed>
      </embed>
      </object>

      <!--
      <APPLET CODE = "MyTestApplet.class" WIDTH = 350 HEIGHT = 200>


      </APPLET>
      -->
      <!--"END_CONVERTED_APPLET"-->

      </p>

      <hr><font><i>Generated by NetBeans IDE</i></font>
      </body>
      </html>

      ---------- END SOURCE ----------

      CUSTOMER SUBMITTED WORKAROUND :
      I specify, in the HTMLConverter, to only use java 1.4.2.
      (Incident Review ID: 193321)
      ======================================================================
      ###@###.### 2003-08-07

        Attachments

          Activity

            People

            Assignee:
            dphamsunw Danielle Pham (Inactive)
            Reporter:
            gmanwanisunw Girish Manwani (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: