Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4910177

TEST_BUG: Regression-test .../metadata/SetAttributeNode.java fails on Tiger-b15

    Details

    • Subcomponent:
    • CPU:
      x86
    • OS:
      solaris_9, solaris_10, windows_xp

      Description



      Name: vsR10238 Date: 08/20/2003


      Filed By : J2SE-SQA [###@###.###
      JDK : JDK1.5.0-b15
      Testbase : Regression-test
      Platform[s] : Windows XP Home, Solaris 10 (sparc) (GNOME), Solaris 9 (x86) (CDE)
      switch/Mode : -client, -server
      Falling test[s]:
               javax/imageio/metadata/SetAttributeNode.java

      Regression-test javax/imageio/metadata/SetAttributeNode.java test fails with JDK1.5.0-b15 on all platforms.
      The test passes with JDK1.5.0-b14

      The cause of the failure is that MyAttrNode does not override abstract method org.w3c.dom.Attr.isId():

      ----------System.err:(4/261)----------
      /net/linux-15/export/home/java/regtest.tiger/test/javax/imageio/metadata/SetAttributeNode.java:109:
      MyAttrNode is not abstract and does not override abstract method isId() in org.w3c.dom.Attr
      class MyAttrNode extends IIOMetadataNode implements Attr {
      ^
      1 error
      result: Failed. Compilation failed




      If you run the test again it produces another output because
      SetAttributeNode.class was created for the previous execution of the test.
      This output can be found in the jtr file.

      org.w3c.dom.Attr.isId() was added for JDK1.5.0-b15 (See org/w3c/dom/Attr.java for details).


      Test source location:
      =====================
      /java/re/jdk/1.5.0/promoted/latest/ws/j2se/test/javax/imageio/metadata/SetAttributeNode.java

      jtr file location:
      ==================
      /net/jtgb4u4c.sfbay/export/sail15/results.2/tiger/b15/regtest/x86/sol9_x86_cde_smp_linux-6/workDir/test/javax/imageio/metadata/SetAttributeNode.jtr

      How to reproduce:
      =================
      Run the following script (you may need to change its variables)

      --- script start ---
      #!/bin/sh

      RESULT_DIR=`pwd`
      WORK_DIR=$RESULT_DIR/workDir/test
      REPORT_DIR=$RESULT_DIR/reportDir
      JT_HOME="/net/linux-15/export/home/java/jct"
      JAVA_HOME="/net/linux-15/export/home/java/jdk1.5.0/x86"
      TEST_BASE_PATH="/net/linux-15/export/home/java/regtest.tiger/test"

      TESTWITH=$JAVA_HOME
      TESTJAVA=$JAVA_HOME

      JTOPTS="-server"
      TESTVMOPTS="-server"

      CLASSPATH="$JT_HOME/classes:$JT_HOME/lib/javatest.jar:$JT_HOME/lib/jtreg.jar:$JT_HOME/jemmy/jemmy.jar"

      export JAVA_HOME
      export JT_HOME
      export TESTWITH
      export CLASSPATH

      mkdir -p $WORK_DIR/scratch 2>&1
      mkdir -p $WORK_DIR/jtData 2>&1
      mkdir -p $REPORT_DIR 2>&1

      #rm $WORK_DIR/jtData/ResultCache.jtw 2>&1

      cd $WORK_DIR/scratch

      $JAVA_HOME/bin/java -cp $CLASSPATH $JTOPTS -DenvVars=TESTJAVAHOME=$JAVA_HOME,TESTVMOPTS=$TESTVMOPTS,DISPLAY=:0,HOME=$HOME/.regtest,PATH=/bin:/usr/bin,CPAPPEND=$JT_HOME/jemmy/jemmy.jar,TZ=,LC_ALL=en_US,LC_CTYPE=en_US,LANG=en_US,LPDEST= -DDISPLAY=:0 -DlocalHost="linux-6" -Dprogram=jtreg com.sun.javatest.regtest.Main -a -v default -batch -params -w "$WORK_DIR" -r "$REPORT_DIR" -t "$TEST_BASE_PATH" "$TEST_BASE_PATH/javax/imageio/metadata/SetAttributeNode.java"

      --- script end ---

      Test output (jtr part):
      =======================
      ----------System.out:(0/0)----------
      ----------System.err:(14/760)----------
      java.lang.NoClassDefFoundError: MyAttrNode
      at SetAttributeNode.test1(SetAttributeNode.java:27)
      at SetAttributeNode.main(SetAttributeNode.java:102)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at com.sun.javatest.regtest.MainWrapper$MainThread.run(MainWrapper.java:82)
      at java.lang.Thread.run(Thread.java:549)

      JavaTest Message: Test threw exception: java.lang.NoClassDefFoundError: MyAttrNode
      JavaTest Message: shutting down test

      STATUS:Failed.`main' threw exception: java.lang.NoClassDefFoundError: MyAttrNode
      result: Failed. Execution failed: `main' threw exception: java.lang.NoClassDefFoundError: MyAttrNode


      test result: Failed. Execution failed: `main' threw exception: java.lang.NoClassDefFoundError: MyAttrNode


      Specific machine info:
      ======================
      Hostname: linux-21
      OS: Windows XP Home
      Hostname: linux-6
      OS: Solaris 9 (x86) (CDE)
      Hostname: linux-8
      OS: Solaris 10 (sparc) (GNOME)



      ======================================================================

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                vshsunw Vsh Vsh (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: