Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4911659

RHAS2.1:Plugin can't work with Mozilla1.4 due to LoadPlugin failed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2
    • Resolution: Cannot Reproduce
    • Affects Version/s: 5.0
    • Fix Version/s: None
    • Component/s: deploy
    • Labels:
    • Subcomponent:
    • CPU:
      x86
    • OS:
      linux

      Description

      ===============================================
      JRE: Tiger jre1.5.0 b16
           j2re-1_5_0-beta-bin-b16-linux-i586-21_aug_2003.bin
      Browser : Moziila 1.4
      OS : RedHat Advanced Server 2.1 (32)
      locale : C, eucJP
      ===============================================

      Plugin can't work on RHAS 2.1(32), Mozilla 1.4 with Tiger b16.

      I linked Mozilla 1.4 with ns7 and launched Moziila1.4.
      Then, I got the erroe messages as below;
      ----------------------------------------
      LoadPlugin: failed to initialize shared library /home/rs88024/jdk150/b16-linux/j2re1.5.0/plugin/i386/ns7/libjavaplugin
      _oji.so [libgcc_s.so.1: cannot open shared object file: No such file or directory]
      ----------------------------------------

      The browser comes up with above error and I opend Help -> about Plug-ins.
      Plug-in for Tiger b16 did no be loaded.

      I tried Mozilla 1.4 with ns7-gcc29 instead of ns7.
      I got a different messages as below;
      -------------------------------------
      INTERNAL ERROR on Browser End: Could not get the plugin manager
      System error?:: Success
      -------------------------------------

      Steps to reproduce;
      1. Install tiger b16 j2re.bin linux bundle.
      2. ln -s JRE_HOME/plugin/i386/ns7/libjavapluin_oji.so
      3. launch mozilla1.4

      Then, you can see the error messages on terminal.

      In Mozilla 1.3,
      Using ns7-gcc29, this problem does not occur. Plugin works fine.
      Using ns7, "LoadPlugin: failed to initialize shared library" occurs.


      ** NOTE **
      This problem does not occur on RedHat9 with Mozilla1.4 & ns7.
      Therefore, this problem occurs only on RHAS 2.1.

      [###@###.### 2003-08-25]

        Attachments

          Activity

            People

            Assignee:
            xlu Xiaobin Lu (Inactive)
            Reporter:
            rsuzukisunw Rieko Suzuki (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: