Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4937520

Vmark fail after 1 min run on windows2003 AMD 64bits with 32 bits VM C2 flag

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1
    • Resolution: Not an Issue
    • Affects Version/s: 5.0
    • Fix Version/s: None
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
    • CPU:
      x86
    • OS:
      windows_2003

      Description

      Vmark fail after 1 min run on windows2003 AMD 64bits with 32 bits VM C2 flag

      JDK version
      =============
      java version "1.5.0-beta"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0-beta-b23)
      Java HotSpot(TM) Server VM (build 1.5.0-beta-b23, mixed mode)

      Platform
      =============
      Windows_NT JTG-AMD2 5 02 586

      Error message
      =============
      Please telnet with root/admin and change to d:\tmp directory to check it.

      #An unexpected error has been detected by HotSpot Virtual Machine:
      # Internal Error (4E4D4554484F440E43505004F6), pid=4068, tid=1568
      # Java VM: Java HotSpot(TM) Server VM (1.5.0-beta-b23 mixed mode)
       --------------- T H R E A D ---------------
       Current thread (0x0d9786f8): JavaThread "Receiver-197" [_thread_in_Java, id=1568]
       Stack: [0x2d970000,0x2d9b0000)
      [error occurred during error reporting, step 110, id 0xe0000000]

      OS: Windows Server 2003 family Build 3790 Service Pack 1, v.1069
      CPU:total 2(active 2) family 15, cmov, cx8, fxsr, mmx, sse, sse2
      Memory: 4k page, physical 1047984k(544108k free), swap 2503324k(1870204k free)
      ###@###.### 2003-10-14


      The error messages first shown up in "run.vmark.out" are:
      java.net.BindException: Address already in use: connect

      The error messages shows up after about 20 iterations.

      From "netstat", it looks like that the ports used by vmark client in previous iterations are not released fast enough. Each vmark client needs 200 ports.
      At the time when the error occurs, the ports used by the new vmark client
      have conflict with the ports used by the older clients which already exit but the ports used by which are not released yet.
       
      I added "sleep 10" after each test iteration so vmark server has more time
      to reclaim ports. The error is gone with the 10 second delay.

      ###@###.### 2003-10-17

        Attachments

          Activity

            People

            Assignee:
            phh Paul Hohensee
            Reporter:
            dchensunw Dxoshin Chen (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: