Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4946991

ONLY RH7.3 vs 1.3.1xx: Regression test fails for 4799941: ORB.shutdown does not

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3
    • Resolution: Not an Issue
    • Affects Version/s: 1.3.1
    • Fix Version/s: None
    • Component/s: other-libs
    • Subcomponent:
    • CPU:
      x86
    • OS:
      linux_redhat_7.3

      Description

      When running the regression tests on RedHat 7.3 the test for 4799941 fails. It also fails for 1.3.1_10b01 and has failed since the fix was put in for 1.3.1_09b01.
      The test passes on RedHat 7.2 but fails on RedHat 9.

      I have attached the test case that shows the failure.
      To reproduce:
      Set PATH to point to JDK under test.
      compile ReaderTest.java
      export TESTCLASSES=.
      run Test4799941.sh
      The number of threads is more than 2 or 3 so test fails

      Here is the jtr file of the failure:

      description=file:///.automount/latte/root/deployment1/regtests/131/test/CTE_REGTEST/Generic/4799941/ReaderTest.java
      end=Thu Oct 30 11:00:30 GMT 2003
      environment=regtest
      execStatus=Failed. Execution failed: exit code 1
      javatestOS=Linux 2.4.18-3smp (i386)
      javatestVersion=2.1.6
      script=com.sun.javatest.regtest.RegressionScript
      sections=script_messages compile shell
      start=Thu Oct 30 11:00:16 GMT 2003
      status=Failed. Execution failed: exit code 1
      test=CTE_REGTEST/Generic/4799941/ReaderTest.java
      work=/home/JQA/ts131/1.3.1_10Regression/work/CTE_REGTEST/Generic/4799941

      #section:script_messages
      ----------messages:(4/195)----------
      JDK under test: (/home/JDKS/jdk1.3.1_10)
      java version "1.3.1_10"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.1_10-b02)
      Java HotSpot(TM) Client VM (build 1.3.1_10-b02, mixed mode)

      #section:compile
      ----------messages:(3/205)----------
      command: compile /.automount/latte/root/deployment1/regtests/131/test/CTE_REGTEST/Generic/4799941/ReaderTest.java
      reason: User specified action: run compile ReaderTest.java
      elapsed time (seconds): 2.323
      ----------System.out:(0/0)----------
      ----------System.err:(0/0)----------
      result: Passed. Compilation successful

      #section:shell
      ----------messages:(3/119)----------
      command: shell Test4799941.sh
      reason: User specified action: run shell Test4799941.sh
      elapsed time (seconds): 12.162
      ----------System.out:(3/68)----------
      Ready.
      Current threads: 1
      After 10 iterations, current threads: 12
      ----------System.err:(4/347)----------
      java full version "1.3.1_10-b02"
      Exception in thread "main" java.lang.RuntimeException: Test Failed
              at ReaderTest.main(ReaderTest.java:45)
      /.automount/latte/root/deployment1/regtests/131/test/CTE_REGTEST/Generic/4799941/Test4799941.sh: line 97: 30096 Killed ${TESTJAVA}${FS}bin${FS}tnameserv -ORBInitialPort 9000 >tname.out 2>&1
      result: Failed. Execution failed: exit code 1

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              hcarr Harold Carr
              Reporter:
              duke J. Duke (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Imported:
                Indexed: