Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4959518

Relook the TLS handlers to support the JSSE unbundled version.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 1.0
    • Fix Version/s: 1.0.1
    • Component/s: core-svc
    • Labels:
      None
    • Subcomponent:
    • Resolved In Build:
      1.0.1
    • CPU:
      sparc
    • OS:
      solaris_2.5.1

      Description

      Attempt to work even if we are running in J2SE 1.3, where the
      unbundled JSSE libraries do not contain the following methods:

      SSLSession.getProtocol()
      SSLSocket.getEnabledProtocols()
      SSLSocket.setEnabledProtocols(String[])
      SSLSocket.getWantClientAuth()
      SSLSocket.setWantClientAuth(boolean)

        Attachments

          Activity

            People

            Assignee:
            lmalvent Luis-Miguel Alventosa (Inactive)
            Reporter:
            lmalvent Luis-Miguel Alventosa (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: