Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-5053921

Application crashes using :XX+UseTLE and -server on Windows

    XMLWordPrintable

    Details

    • Subcomponent:
    • Resolved In Build:
      b01
    • CPU:
      x86
    • OS:
      windows_2000

      Description

      The application crashes at boot time when using 1.3.1_12-b02 (_11 as well)
      use UseTLE in conjunction with the -server option on Windows.

      Symptoms:
      The application crashes always with-server -XX+UseTLE. -printCompilation shows that it crashes with different methods being compiled.
      Excluding methods allows the application to progress. It however crashes
      later (methods being excluded 3 times with and without -xcomp).

      The application never crashes with -Xint or -client in conjunction with -XX:UseTLE.

      The application crashes without any hot spot err id.

      The application crashes as well with a fulldebug version.
      It runs into assertion failures.

      See two following logs.

      Assertion seems to be


      # assert(_no_handle_mark_nesting == 0, "allocating handle inside NoHandleMark")

      #

      # Error ID: D:\BUILD_AREA\jdk131-update\ws\fcs\hotspot\src\share\vm\runtime\handles.cpp, 18

      #

      # Problematic Thread: prio=5 tid=0x6d346d90 nid=0x188c runnable

      #

      [error occured during error reporting]

      see attachment trace2.txt

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              minqi Yumin Qi
              Reporter:
              stschnei Stefan Schneider (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Imported:
                Indexed: