Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-5062711

Spelling errors in J2SE API docs

    Details

    • Subcomponent:
    • Resolved In Build:
      b81
    • CPU:
      x86
    • OS:
      linux

      Description

      Name: gm110360 Date: 06/14/2004


      A DESCRIPTION OF THE PROBLEM :
      The J2SE 1.5 API docs contain the following spelling errors:

      1) "See Appendix A in the Java Cryptogaphy" (note "Cryptogaphy") in:
      - java.security.Security.getProviders(String filter)
      - java.security.Security.getProviders(Map<String,String> filter)

      2) "becasue" in:
      - javax.print.attribute.UnmodifiableSetException (class javadoc)

      3) Apparently copy-pasted docs, referring to UnsupportedOperationException in:
      - javax.print.attribute.UnmodifiableSetException.UnmodifiableSetException()

      EXPECTED VERSUS ACTUAL BEHAVIOR :
      EXPECTED -
      1) Cryptography

      2) because

      3) UnmodifiableSetException
      ACTUAL -
      1) Cryptogaphy

      2) becasue

      3) UnsupportedOperationException

      URL OF FAULTY DOCUMENTATION :
      http://java.sun.com/j2se/1.5.0/docs/api/index.html
      (Incident Review ID: 279898)
      ======================================================================

        Attachments

          Activity

            People

            • Assignee:
              shainessunw Suzette Haines (Inactive)
              Reporter:
              gmanwanisunw Girish Manwani (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported:
                Indexed: