Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-5078729

Java 2D FAQ is out of date

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P4
    • Resolution: Cannot Reproduce
    • Affects Version/s: 5.0
    • Fix Version/s: None
    • Component/s: client-libs
    • Labels:
    • Subcomponent:
      2d
    • CPU:
      generic
    • OS:
      generic

      Description

      Name: nl37777 Date: 07/26/2004

      The Java 2D FAQ is out of date; it looks like it hasn't
      been updated for over two years. Below are just some of the items that
      need to be updated; I suspect imaging experts would find more.

      J2SE versions: The FAQ talks about JDK 1.1 and J2SE 1.2 as part of the
      present, J2SE 1.4 as the future. JDK 1.1 and J2SE 1.2 are EOL; J2SE 1.4
      and 5.0 are the present.

      Browsers: The statement "the problem is that most browsers do not
      support the Java 2 platform" isn't quite true anymore, and the plugin
      is now a standard part of any J2SE distribution.

      JavaOne: JavaOne 2001 is history. So are 2002, 2003, and 2004.

      Other information sources: There now is an Internationalization home
      page at http://java.sun.com/j2se/corejava/intl/index.jsp and an
      Internationalization FAQ page at
      http://java.sun.com/j2se/corejava/intl/reference/faqs/index.html.

      Fonts: The statement about supported font types differs from that in
      http://java.sun.com/j2se/1.4.2/docs/guide/intl/font.html.

      Writing directions: Java 2D doesn't support all different writings that
      matter for Japanese, e.g., it doesn't support vertical text or
      right-to-left rendering for Japanese.

      font.properties, logical fonts, adding fonts: font.properties files
      don't exist anymore in J2SE 5.0. Logical fonts are not maintained for
      backward compatibility, but because they are an essential ingredient in
      the development of internationalized applications. Adding fonts in J2SE
      5.0 is much simpler than in J2SE 1.3.1 or 1.4.2. These three questions
      are best replaced with a link to
      http://java.sun.com/j2se/corejava/intl/reference/faqs/
      index.html#desktop-rendering

      Lucida: All three Lucida fonts are distributed with JREs for Linux. The
      supported character sets are small ones - "large" would be CJK
      character sets, which aren't supported. There's more information at
      http://java.sun.com/j2se/1.4.2/docs/guide/intl/font.html.

      Besides being out of date, the FAQ is located in two places; one would
      probably be enough:
      http://java.sun.com/products/java-media/2D/reference/faqs/index.html
      http://java.sun.com/products/java-media/2D/forDevelopers/java2dfaq.html
      ======================================================================

        Attachments

          Activity

            People

            Assignee:
            prr Philip Race
            Reporter:
            nlindenbsunw Norbert Lindenberg (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: