Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-5101943

SWAT:Incorect version is displayed in Netscape/Mozilla for Tiger Update

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2
    • Resolution: Duplicate
    • Affects Version/s: 5.0u1
    • Fix Version/s: None
    • Component/s: deploy
    • Subcomponent:
    • CPU:
      generic
    • OS:
      windows

      Description

      Incorect version is displayed in Netscape/Mozilla for Tiger Update on windows only.

      Steps to reproduce:
      1. Install jdk/jre from /net/mizu.sfbay/usr/re/jdk1.5.0_01/bundles/windows-i586/latest
      2. Launch the browser Netscape/Mozilla
      3. Check the installed plug-ins in Help --> About Plug-ins

      "Java(TM) Platform Standard Edition 5.0_01" is displayed

      Should be 1.5.0_01

      See also e-mail from Brian Beck "Naming FAQ Update"
      "In particular, I wanted to point out that Tiger's update releases are known as "5.0 Update 1", "5.0 Update 2" and so on. In "java -version" and a few other places where compatibility is important you will see "1.5.0_01". Note however that you should never see "5.0_01".

      Note:
      Correct version 1.5.0_01 is displayed in Netscape/Mozilla on Solaris/Linux platforms.

      Should be consistent everywhere.

      ###@###.### 2004-09-14

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                billyh William Harnois
                Reporter:
                lshikhva Ludmila Shikhvarg (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: