Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-5108173

Mozilla Firefox does not detect the required version of plugin

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 5.0
    • Fix Version/s: 5.0
    • Component/s: deploy
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      beta
    • CPU:
      x86
    • OS:
      windows_xp
    • Verification:
      Verified

      Description

      Platform: windows
      Browser: Mozilla Firefox version 1.0 Preview Release

      Problem:
      -------
      When users load a J2SE 5.0 specific demonstration applet, Firefox's Plugin Finder Service shows the only available Plugin download which is "Sun Java v1.4.2_05". It does not detect that the applet is specific to Tiger (application/x-java-applet;jpi-version=1.5)


      Steps to reproduce:
      ------------------

      1) Making sure that your test windows machine does not have j2re 1.5
      2) Using Firefox- v1 PR to load any 1.5 specific applet at
         http://java.sun.com/products/plugin/1.5.0/demos/plugin/applets.html

      Firefox's Plugin Finder Service displays the only available Plugin download which is "Sun Java v1.4.2_05". This is not a correct behaviour since 1.5 is required to run the applet.

      This bug will affect our autodownload feature in Firefox.
      ###@###.### 10/9/04 17:44 GMT

        Attachments

          Activity

            People

            • Assignee:
              dphamsunw Danielle Pham (Inactive)
              Reporter:
              hungnguy Hung Nguyen (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported:
                Indexed: