Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6193821

Sanity.gmk in Tiger/mustang j2se workspace contains incorrect error message

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 5.0u2
    • Fix Version/s: 5.0u2
    • Component/s: infrastructure
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b05
    • CPU:
      generic
    • OS:
      generic

      Backports

        Description

        Sanity.gmk in the Tiger's j2se workspace has the following incorrect error messages:
        ifeq ($(PLATFORM), windows)
          ifeq ($(ARCH_DATA_MODEL), 32)
                @#
                @# Check windows compiler type
                @#
                @if [ ! "x$(CC_TYPE)" = "x$(REQUIRED_CCTYPE)" ]; then \
                  $(ECHO) "ERROR: To build Java 2 SDK 1.4 you need : \n" \
                    " $(COMPILER_NAME) - cl.exe type \"$(REQUIRED_CCTYPE)\" \n" \
                    " You are using Compiler type \"$(CC_TYPE)\" \n" \
                    " Please install the required version of Visual C++ and start
        your build again. \n" \
                    "" >> $(ERROR_FILE) ; \
                fi
          endif
                @#
                @# Check the version of Visual C++ cl.exe by parsing off the version
        number from the banner
                @#
                @if [ ! "x$(CC_VER)" = "x$(REQUIRED_CCVER)" ]; then \
                  $(ECHO) "ERROR: To build Java 2 SDK 1.4 you need : \n" \
                    " $(COMPILER_NAME) - cl.exe version \"$(REQUIRED_CCVER)\" \n" \
                    " You are using Compiler version \"$(CC_VER)\" \n" \
                    " Please install the required version of Visual C++ and start
        your build again. \n" \
                    "" >> $(ERROR_FILE) ; \
                fi
                @#
                @# Check the version of Visual C++ link.exe by parsing off the version
        number from the banner
                @#
                @if [ ! "x$(LINK_VER)" = "x$(REQUIRED_LINKVER)" ]; then \
                  $(ECHO) "ERROR: To build Java 2 SDK 1.4 you need : \n" \
        ###@###.### 2004-11-11 04:33:10 GMT

        Please also check the Sanity.gmk files in other workspaces as well.
        Fix them if needed.
        ###@###.### 2004-11-11 22:53:20 GMT

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                asaha Abhijit Saha
                Reporter:
                ccheung Calvin Cheung
                Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: