Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6201982

Solaris 8 Build patch requirement change, need 109147-32/109148-32 (ld/dtrace issue)

    XMLWordPrintable

    Details

    • Subcomponent:
    • Resolved In Build:
      b07
    • CPU:
      generic
    • OS:
      generic
    • Verification:
      Verified

      Description

      Solaris 8 Build patch requirement change, need 109147-32/109148-32 (ld/dtrace issue)

      The build machines need this newer ld so that the jhelper.o file is
      linked in properly to libjvm.so.

      This patch isn't formally/publicly available just yet, as of this writing,
      so we need to figure out how to handle changing the RE build machines.

      I assume some build documentation will also need to change.

      This is critical for ALL Tiger update builds, and also all Mustang
      builds.

      This is NOT a runtime patch requirement, just a build time issue.

      The user runtime issue is when dtrace is used on Solaris 10, which needs
      build 73 or newer, like fcs. Dtrace can only be used on Solaris 10.
      There are currently no automated dtrace tests.



      ---
      Note: Developers using Solaris 9 will need to make sure they have
      Solaris 9 patches 112963-17/113986-13 if they build libjvm.so and want to
      use dtrace on Solaris 10 with their build.


        Attachments

          Issue Links

            Activity

              People

              Assignee:
              duke J. Duke (Inactive)
              Reporter:
              ohair Kelly Ohair (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Imported:
                Indexed: