Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6330315

(se) Selectors should use epoll on Linux

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 6
    • Fix Version/s: 6
    • Component/s: core-libs
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b59
    • CPU:
      generic
    • OS:
      generic

      Backports

        Description

        Modern Linux kernels (>= 2.6) support the epoll(4) facility, which like the
        /dev/poll facility on Solaris is a much more scalable version of the classic
        poll(2) kernel call. For better performance the default selector provider on
        Linux should use epoll whenever possible.

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  alanb Alan Bateman
                  Reporter:
                  mr Mark Reinhold
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Imported:
                    Indexed: