Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6332554

activation.jar version 1.1.0 build 20 does not allow compilation with JDK1.4

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: 4.0
    • Fix Version/s: 1.1
    • Component/s: other-libs
    • Labels:
      None
    • Subcomponent:
    • Resolved In Build:
      1.1
    • CPU:
      sparc
    • OS:
      solaris_10

      Description

      When using
      /s/b/i/jaf/1.1.0/b20/common/activation.jar
      in the message queue build classpath using JDK1.4, we get the following error:
      You should allow products to still use JDK1.4 with activation.jar
      in the build classpath by using the "-target 1.4" option to javac
      when generating activation.jar.

      javax.activation.DataHandler
      bad class file:
      /net/redbuild.red.iplanet.com/export/builds/integration/jaf/1.1.0/b20/common/act
      ivation.jar(javax/activation/DataHandler.class)
      class file has wrong version 49.0, should be 48.0
      Please remove or make sure it appears in the correct subdirectory of the
      classpath.
      import javax.activation.DataHandler;
                              ^
      1 error

        Attachments

          Activity

            People

            • Assignee:
              duke J. Duke (Inactive)
              Reporter:
              jlsato Jill Sato (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported:
                Indexed: