Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6363678

System hangs when appending multiple lines of text to TextArea, XAWT

    Details

    • Subcomponent:
    • CPU:
      sparc
    • OS:
      solaris_10

      Description

      Problem Description :
           I have a frame , Textarea & a button. On clicking the button, I am generating some integer nos & appending to the textarea. The problem is that , after clicking the button it takes few seconds to see the appended lines on the textarea. On SolSparc10, the system hangs immediately after all the lines are appended and I had to reboot it to restore it.

      The hang is reproducible only on SolSparc10 where as the initial delay is reproducible on Cinnabar as well as SolSparc10. I am able to reproduce these issues with Tiger as well as Mustang with XAWT. Not reproducible on Motif and hence this may appear as a regression in Mustang. I reproduced it with Mustang-b63.

      To reproduce, run the attached test and click on the print button. If you don't see any lines being appended to the textarea or if the system hangs soon after repaint, the bug is reproduced.
      System did not hang , after updating the patch (solaris). I tested with b68. Its working fine.

        Attachments

          Activity

            People

            • Assignee:
              yan Yuri Nesterenko
              Reporter:
              lpremkumsunw Lawrence Premkumar1 (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported:
                Indexed: