Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6376334

AppletViewer throws IOException

    Details

    • Subcomponent:
    • Introduced In Build:
      b61
    • Introduced In Version:
      6
    • Resolved In Build:
      b73
    • CPU:
      x86
    • OS:
      windows_xp

      Description

      This issue was reported agains NetBeans but it seems it is an appletviewer bug. When user creates java project, add an applet into it and try to run this applet IOExcception is thrown:
      I/O exception while reading: D:\MyDocuments\Temp\TestJava6Applet\D:\MyDocuments\Temp\TestJava6Applet\build\NewApplet.html (The filename, directory name, or volume label syntax is incorrect)
      Java Result: 1

      applet.url property in run-applet target in build script of the java project is set correctly when this target is called.

      Here is the ant debug information when run-applet target is called:
      run-applet:
      Executing 'C:\java\jdk1.6.0\jre\bin\java.exe' with arguments:
      '-Djava.security.policy=applet.policy'
      '-classpath'
      'D:\dev\moje\JavaApplication1\build\classes'
      'sun.applet.AppletViewer'
      'file:D:/dev/moje/JavaApplication1/build/NewApplet.html'
      The ' characters around the executable and arguments are
      not part of the command.
      Execute:Java13CommandLauncher: Executing 'C:\java\jdk1.6.0\jre\bin\java.exe' with arguments:
      '-Djava.security.policy=applet.policy'
      '-classpath'
      'D:\dev\moje\JavaApplication1\build\classes'
      'sun.applet.AppletViewer'
      'file:D:/dev/moje/JavaApplication1/build/NewApplet.html'
      The ' characters around the executable and arguments are
      not part of the command.
      I/O exception while reading: D:\dev\moje\JavaApplication1\D:\dev\moje\JavaApplication1\build\NewApplet.html (The filename, directory name, or volume label syntax is incorrect)
      Java Result: 1
      BUILD SUCCESSFUL (total time: 1 second)
      Could not load a dependent class (com/sun/media/jai/codec/FileSeekableStream) for type image
      Could not load a dependent class (jdepend/xmlui/JDepend) for type jdepend

      This problem is reproducible only with mustang on windows. On other platforms and with previous java versions it works fine.

      For more info see:
      http://www.netbeans.org/issues/show_bug.cgi?id=71505

      I'm not sure if it can be related to bug #6193279.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                dcherepanov Dmitry Cherepanov
                Reporter:
                radko Radko Najman (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: