Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6401856

AWT/InputMethods: Would be nice to be able compile AWT against OpenMotif

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Won't Fix
    • Affects Version/s: 6
    • Fix Version/s: None
    • Component/s: client-libs
    • Labels:

      Description

      If you try and build the j2se workspace on a typical modern Linux, the obvious version of Motif to use is OpenMotif. If you use that, it is reasonably easy to get the entire workspace to build, with the exception of one line of code in src/solaris/native/sun/awt/awt_motif21.c. The line is a call to _XmImGetGeo in awt_motif_getIMStatusHeight.

      It would be nice if this file could be compiled against the latest OpenMotif, thereby allowing the entire j2se workspace to be build "out-of-the-box" on Linux.

      I acknowledge this is not the version of Linux that Sun supports for building on, but I would say it is a typical one for Peabody users.

      (For reference, I'm using SuSE 10.)

        Attachments

          Activity

            People

            • Assignee:
              naoto Naoto Sato
              Reporter:
              jjg Jonathan Gibbons
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported:
                Indexed: