Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6449023

Crash in JDI test against ForceEarlyReturn

    Details

    • Subcomponent:
    • CPU:
      generic
    • OS:
      generic

      Description

      Following JDI test fails because of debuggee VM crashes:
      nsk/jdi/ThreadReference/forceEarlyReturn/forceEarlyReturn007
      (this test should be included in testbase r07)

      This test starts in debuggee VM 20 threads and for one of them calls several times forceEarlyReturn (through com.sun.jdi.ThreadReference), test crashes very fast.

      Bug is reproduces on all platforms.

      hs_err file is attached.

        Issue Links

        There are no Sub-Tasks for this issue.

          Activity

          Hide
          sspitsyn Serguei Spitsyn added a comment -
          This crash is different that what we have seen before.
          I'll try to check if it is a relatively recent regression.
          Show
          sspitsyn Serguei Spitsyn added a comment - This crash is different that what we have seen before. I'll try to check if it is a relatively recent regression.
          Hide
          cjplummer Chris Plummer added a comment - - edited
          It appears to have been introduced yesterday. I could not reproduce it with any of the nightly binaries. Then I grabbed yesterday's nightly binary later in the day and it does reproduce with it. There were 4 compiler related commits yesterday.
          Show
          cjplummer Chris Plummer added a comment - - edited It appears to have been introduced yesterday. I could not reproduce it with any of the nightly binaries. Then I grabbed yesterday's nightly binary later in the day and it does reproduce with it. There were 4 compiler related commits yesterday.
          Hide
          sspitsyn Serguei Spitsyn added a comment - - edited
          I cloned the jdk/hs repository yesterday night and built the fastdebug image locally on linux-x64.
          Can't reproduce it yet . Should I use any specific options?
          I've alreay tried: "-Xcomp -server -XX:TieredStopAtLevel=1", and " -Xmixed -server -XX:+UseG1GC".
          Show
          sspitsyn Serguei Spitsyn added a comment - - edited I cloned the jdk/hs repository yesterday night and built the fastdebug image locally on linux-x64. Can't reproduce it yet . Should I use any specific options? I've alreay tried: "-Xcomp -server -XX:TieredStopAtLevel=1", and " -Xmixed -server -XX:+UseG1GC".
          Hide
          cjplummer Chris Plummer added a comment -
          It looks like it is due to JDK-8160548. I'm running again with the patch back in to verify.
          Show
          cjplummer Chris Plummer added a comment - It looks like it is due to JDK-8160548 . I'm running again with the patch back in to verify.
          Hide
          cjplummer Chris Plummer added a comment -
          I'm closing as CNR again and created JDK-8191733 for this new assert.
          Show
          cjplummer Chris Plummer added a comment - I'm closing as CNR again and created JDK-8191733 for this new assert.

            People

            • Assignee:
              sspitsyn Serguei Spitsyn
              Reporter:
              sboikovsunw Semen Boikov (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported:
                Indexed: