Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6449504

REGRESSION:ZipException exception throws when try to read a XML file

    Details

    • Subcomponent:
    • Resolved In Build:
      b97
    • CPU:
      x86
    • OS:
      windows_xp

      Description

      J2SE Version (please include all output from java -version flag):
       1.6.0-rc-b91

      Does this problem occur on J2SE 1.4.x or 5.0.x ?
        No, and does not happen in 1.6.0-rc-b76

      Operating System Configuration Information (be specific):
        XP + SP2

      Hardware Configuration Information (be specific):
        Pentium 4, 3.00 GHz, 504 MB RAM.

      Bug Description:
       Moved to the latest build (91) after working with build 76 and application stopped working:
       It throws the following exception while trying to read a XML file:

      java.util.zip.ZipException: ZipFile closed
      at java.util.zip.ZipFile.ensureOpenOrZipException(Unknown Source)
      at java.util.zip.ZipFile.access$1100(Unknown Source)
      at java.util.zip.ZipFile$ZipFileInputStream.read(Unknown Source)
      at java.util.zip.ZipFile$ZipFileInputStream.read(Unknown Source)
      at java.io.FilterInputStream.read(Unknown Source)
      at org.apache.xerces.impl.XMLEntityManager$RewindableInputStream.read(Unknown Source)
      at org.apache.xerces.impl.XMLEntityManager.setupCurrentEntity(Unknown Source)
      at org.apache.xerces.impl.XMLVersionDetector.determineDocVersion(Unknown Source)
      at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
      at org.apache.xerces.parsers.DTDConfiguration.parse(Unknown Source)
      at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
      at org.apache.xerces.parsers.DOMParser.parse(Unknown Source)
      at com.mercury.ftjadin.utils.xmlParsing.DomParserFactory.run(DomParserFactory.java:112)


      Steps to Reproduce (be specific):
        It happens when calling org.apache.xerces.parsers.DOMParser.parse for a XML
        file that is in a jar within the class path.
      a sample application reproducing the bug had been added into the bug report.
      The application works correctly on build 76 but fails on 91.
      To use it, extract the attached zip, to c:\temp (you must use this hardcoded folder).
      Then run the file c:\temp\mustandBug\run.bat

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                michaelm Michael McMahon
                Reporter:
                tyao Ting-Yun Ingrid Yao (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: