Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6450393

api/xsl/conf/string/string134.html and string135.html: due to wrong representation of decimal point

    Details

    • Subcomponent:
    • Resolved In Build:
      b96
    • CPU:
      generic
    • OS:
      generic, windows
    • Verification:
      Verified

      Description

      JCK : JCK6.0 b28
      J2SE : FAIL - mustang b91
      Platform[s] : FAIL - seems to be all
      switch/Mode : FAIL - default

      see evalution for more information.

      old description is:

      Three tests:
      api/xsl/conf/string/string134.html#string134[testTransformation]
      api/xsl/conf/string/string135.html#string135[testTransformation]
      api/xsl/conf/math/math110.html#math110[testTransformation]

      fail on *Windows platforms only* due to adding 0D before 0A. Tests try to start new line using construction like this:

      <xsl:text>&#10;</xsl:text>

      On windows targets this causes adding not only 0A but also 0D into output document. As a result tests fail (it doesn't expect 0D).

      Please don't close this bug but reassign to tck_j2se if this is expected behaviour.

      .jtrs and test sources attached.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                spericas Santiago Pericasgeertsen
                Reporter:
                pastepan Pavel Stepanov (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: