Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6462356

Solaris only: IME can not be turned on when NetBeans IDE running on JDK1.6

    XMLWordPrintable

    Details

    • Subcomponent:
    • Resolved In Build:
      b98
    • CPU:
      x86
    • OS:
      solaris_10

      Description

      IME can not be turned on when I use NetBeans with JDK1.6 on Solaris.

      Environment:
        Java: 1.6.0-rc-b96
        NetBeans IDE 5.0 (Build 200603142030)
      http://www.netbeans.info/downloads/download.php?type=5.0
      We can use English version for testing.
        SunOS 5.10 Generic_118855-15 (x86)
      I'm seeing this problem on Solaris SPARC too.
      Latest patches have been applied. ATOK is now based on ATOK17,
      IIMF is also updated version (which are not bundled in pure Solaris
      10 release). Detail output of `showrev -v` is attached.
        Desktop: JDS
        System locale: ja_JP.eucJP, ja_JP.UTF-8

      Step:

      1. Start NetBeans with JDK1.6.0 (assuming installed in /opt/jdk1.6.0)

      % netbeans --jdkhome /opt/jdk1.6.0

      2. Try to turn IME on in any input field
         For example, File>Open Project, select input field then Ctrl+SPACE
         
         but nothing happens. IME is not activated.

      3. Try with JDK1.5

      % netbeans --jdkhome /opt/jdk1.5.0_07

          Now IME can be turned on.

      When I tried JDK1.6 with NetBeans on another platforms - Fedora Core 5,
      and Windows XP, it works fine.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              yyamasaksunw Yuriko Yamasaki (Inactive)
              Reporter:
              katakai Masaki Katakai
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Imported:
                Indexed: