Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6466876

Applet frame is not repainted correctly

    XMLWordPrintable

    Details

    • Subcomponent:
    • Resolved In Build:
      b02
    • CPU:
      x86
    • OS:
      windows_xp

      Description

      Running customer's application on 5.0u9 b01. The applet frame is not repainted correctly.
      In 5.0u7,5u8, the problem seems to appear less frequently.

      Platform: XP-Pro
      Browser: IE 6

      Steps to reproduce:
      ------------------
      - Install 5.0u9-b01 onto the test system.
      - Using Internet Explorer 6,
        browse http://10.5.21.113/Stardom/Hmi/Run/TC50-01
      - Click "Logon" on the left frame.
      - "Logon" page is shown. Click "Logon" button (leave the User ID and Password field EMPTY)
      - Click "Graphics" on the left frame.
      - Click "Objects" on the left frame.
      - Click "TC50-01-01" (left side under [Graphic Index] section).
      (the page should be displayed in the middle frame)
      - Click "Group01.AI001" on the left (under [server-id] section).
      (the page should be displayed in the right frame)
      - In the middle frame, slide the knob (of the vertical scrollbar) toward the end of the
        horizontal scrollbar, then do the refresh of the middle frame (by right click on the
        middle frame and click "Refresh").

      ----> The right frame isn't repainted correctly. (see the attached screenshot)

      Retested this reported issue internally, and here 's what we observed:
      - In 5.0u7, 5.0u8, it seems that the problem appears less frequently.
      - In 5.0u9-b01- the problem does exist.

      - When the repaint problem occurs:
          + You can minimize and then restore/maximize the Internet Explorer again, then the
            applet page is repainted and the "Group01.AI001" displayed correctly on the right
            frame.
          + Also, if you keep doing the refresh again and again, it will be repainted.

      - If you try to refresh the whole IE browser (from the "View"--> Refresh), the "Group01.AI001" frame is displayed correctly as always


      For further information, contact <###@###.###>
      It seems a regression since 5.0u7-b02.

        Attachments

          Activity

            People

            Assignee:
            mleisunw Mike Lei (Inactive)
            Reporter:
            hungnguy Hung Nguyen (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: