Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6467921

Backport SunPKCS11 to a Tiger update on 64 bit AMD Linux platform

    Details

      Description

      We have an issue with building and running appserver on JDK 5.0 AMD64
      Linux. We have run into this before and now we also see this
      reported by someone on the GlassFish forum -
      http://forums.java.net/jive/thread.jspa?threadID=17639&tstart=45

      The issue relates to absence of sunpkcs11.jar (and related files
      possibly some .so files) in JDK 5.0 on AMD64 Linux versions. Currently,
      appserver cannot be build on AMD64 Linux systems. The
      reason is that appserver code (EESecuritySupportImpl.java) uses a
      class (SunPKCA11) that is avilable only in the sunpkcs11.jar.


      These files however do exist in JDK 6.0 AMD64 Linux builds. Since JDK 5.0 is the
      primary JDK for building and running 9.1 release, I feel that not
      having this would limit our users from running the appserver on a 64 bit Linux platform
      on AMD boxes. Sun produces a whole bunch of AMD 64 based hardware,
      and if the users chooses to install 64 bit Linux on it (like Ubantu),
      they are out of luck.

      The fact that this support is available on JDK 6.0 lead me to believe
      that we could get this backported to JDK 5.0 too.

        Attachments

          Activity

            People

            • Assignee:
              asaha Abhijit Saha
              Reporter:
              dhpande Dhiru Pandey
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported:
                Indexed: