Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6472710

Obseleted SUNWj3* packages are not removed during upgrade from s9/s10 to snv_48.

    XMLWordPrintable

    Details

    • Subcomponent:
    • Resolved In Build:
      solaris
    • CPU:
      generic
    • OS:
      solaris_nevada
    • Verification:
      Not verified

      Description

      This is found in upgrade regression test in snv_48 when I try to verify a fix for upgrade. This impacts both sparc and x86.

      I did the following install:

      OS: Solaris 9 Update 8 FCS
      Media: DVD net image
      Cluster to install: SUNWCXall
      Locales to install: ALL
      Locale to use: C

      Then I upgrade to snv_48 as follow:

      OS: snv_48
      Media: DVD net image
      Upgrade method: Live Upgrade or regular upgrade

      After the upgrade, the following Java 1.4.2 packages are left on the system and not removed:

      SUNWj3cfg
      SUNWj3dev
      SUNWj3dmo
      SUNWj3dvx
      SUNWj3jmp
      SUNWj3man
      SUNWj3rt
      SUNWj3rtx


      The following incorrect entries are in the .pkghistory:

      PKG=SUNWj3cfg
      ARCH=sparc
      VERSION=1.4.2
      REMOVE_FROM_CLUSTER=ALL
      PKG=SUNWj3dev
      ARCH=sparc
      VERSION=1.4.2
      REMOVE_FROM_CLUSTER=ALL
      PKG=SUNWj3dmo
      ARCH=sparc
      VERSION=1.4.2
      REMOVE_FROM_CLUSTER=ALL
      PKG=SUNWj3dvx
      ARCH=sparc
      VERSION=1.4.2
      REMOVE_FROM_CLUSTER=ALL
      PKG=SUNWj3irt
      ARCH=sparc
      VERSION=1.2
      REMOVE_FROM_CLUSTER=ALL
      PKG=SUNWj3jmp
      ARCH=sparc
      VERSION=1.4.2
      REMOVE_FROM_CLUSTER=ALL
      PKG=SUNWj3man
      ARCH=sparc
      VERSION=1.4.2
      REMOVE_FROM_CLUSTER=ALL
      PKG=SUNWj3rt
      ARCH=sparc
      VERSION=1.4.2
      REMOVE_FROM_CLUSTER=ALL
      PKG=SUNWj3rtx
      ARCH=sparc
      VERSION=1.4.2
      REMOVE_FROM_CLUSTER=ALL


      The VERSION 1.4.2 will never work because it will always fails the upgrade criteria of:

      The .pkghistory entry "matches" a currently-
      installed package if the PKG and ARCH values are the same as
      those for the package and the VERSION string of the installed
      package meets the following criterion:

              low_version <= package_version < high_version



      We should use 1.4.3 or higher in order for SUNWj3* packages to be removed.

        Attachments

          Activity

            People

            Assignee:
            katleman David Katleman (Inactive)
            Reporter:
            mmding Mary Ding (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: