Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6476292

J2SE 4 Clients cannot use activation.jar

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: 1.1.1
    • Fix Version/s: 1.0.3
    • Component/s: other-libs
    • Labels:
      None
    • Subcomponent:
    • Introduced In Build:
      1.0.3
    • Introduced In Version:
    • Resolved In Build:
      1.0.3
    • CPU:
      sparc
    • OS:
      solaris_10

      Description

      This has been discovered in JES 5. The classes in activation.jar for Solaris have been compiled with J2SE 5. As a result, J2SE 4 clients will experience a class loader error:
      Exception in thread "main" java.lang.UnsupportedClassVersionError: javax/activation/DataSource (Unsupported major.minor version 49.0)

      Observation: In HPUX and In Windows the error is not reproducible as the activation.jar file has been built using Java SE 1.4.2.

        Attachments

          Activity

            People

            Assignee:
            duke J. Duke (Inactive)
            Reporter:
            duke J. Duke (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: