Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6511454

VM crash on Gentoo on launching any application with Frames

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P4
    • Resolution: Cannot Reproduce
    • Affects Version/s: 6, 6u25
    • Fix Version/s: None
    • Component/s: client-libs
    • Subcomponent:
    • CPU:
      x86
    • OS:
      linux, linux_oracle_6.0

      Description

      FULL PRODUCT VERSION :
      java version "1.6.0"
      Java(TM) SE Runtime Environment (build 1.6.0-b105)
      Java HotSpot(TM) 64-Bit Server VM (build 1.6.0-b105, mixed mode)

      FULL OS VERSION :
      Linux xyz 2.6.18-gentoo-r4 #1 SMP Sat Dec 16 17:13:55 CET 2006 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4400+ AuthenticAMD GNU/Linux

      A DESCRIPTION OF THE PROBLEM :

      Any application started with JDK 6 results in this:

      #
      # An unexpected error has been detected by Java Runtime Environment:
      #
      # SIGSEGV (0xb) at pc=0x00000030b242de54, pid=30743, tid=1090758992
      #
      # Java VM: Java HotSpot(TM) 64-Bit Server VM (1.6.0-b105 mixed mode)
      # Problematic frame:
      # C [libc.so.6+0x2de54] catgets+0x14
      #
      # An error report file with more information is saved as hs_err_pid30743.log
      #
      # If you would like to submit a bug report, please visit:
      # http://java.sun.com/webapps/bugreport/crash.jsp
      #
      Aborted

      I found out, that console programs work (i.e. System.out.println("Hello
      World!") but everything that uses any Frames (GUI) does not work. I.e. the
      following program does not work with JDK 6:

      import javax.swing.JFrame;

      public class Test {

              public static void main(String[] args) {
                      JFrame frame = new JFrame();
                      frame.pack();
                      frame.setVisible(true);
              }

      }

      I also managed to get JDK 6 working. Please see my forum entry at the gentoo
      forums: http://forums.gentoo.org/viewtopic-t-527808-highlight-.html
      (especially my reply). But it turned out, that it workes only
      occassionally.

      I'm afraid I can not help you reproducing the problem, because just anything
      that uses Swing/AWT crashes. I'm completely re-installing my system. I hope
      the problem goes away with that.

      I tried everything: recompiling my whole system, prelinking everything.. etc..

      THE PROBLEM WAS REPRODUCIBLE WITH -Xint FLAG: Yes

      THE PROBLEM WAS REPRODUCIBLE WITH -server FLAG: Yes

      STEPS TO FOLLOW TO REPRODUCE THE PROBLEM :
      Execute any java app with frames.

      ERROR MESSAGES/STACK TRACES THAT OCCUR :
      Attached separatly

      REPRODUCIBILITY :
      This bug can be reproduced always.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                dav Andrei Dmitriev (Inactive)
                Reporter:
                ndcosta Nelson Dcosta (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: