Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6511744

JRadioButton in JTree is not painted in correct state on Vista

    XMLWordPrintable

    Details

    • Subcomponent:
    • Introduced In Version:
      6
    • Resolved In Build:
      b10
    • CPU:
      generic
    • OS:
      windows_vista
    • Verification:
      Verified

      Backports

        Description

        from ###@###.###:
        I am trying to figure out the cause of some strange behavior of JRadioButtons embedded in JTree on Vista. This is happening in Advanced tab of Java Control Panel. There is a JTree containing nodes of JRadioButton(s). Multiple radio buttons are painted selected on windows Vista. You can see this on example of Java console node. The buttons get selected pretty much randomly. The radio button I click on usually is the one NOT selected, while the other two or more (or none at all) would get selected.

        I noticed that this behavior is happening with Vista colors and appearance. If I change the windows appearance to Classic this is not happening. With JRE 1.5.0_09 this is not happening either even with Vista Aero appearance.
        I suspect that this behavior has something to do with vista L&F implementation. Could you please take a look at this? This is rather urgent since it makes the Java Control Panel totally useless on Vista.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                idk Igor Kushnirskiy (Inactive)
                Reporter:
                idk Igor Kushnirskiy (Inactive)
                Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: