Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6609139

Plugin2: Animation Panel has Java 6 dependency

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 6u5
    • Fix Version/s: 6u10
    • Component/s: deploy
    • Labels:
    • Subcomponent:
    • Introduced In Build:
      b08
    • Introduced In Version:
    • Resolved In Build:
      b09
    • CPU:
      generic
    • OS:
      generic

      Description

      The new plugin supports runngin java applets in 1.4.2 and 1.5 JVM. Deploy and plugin code on client vm side need be compatible with as low as 1.4.2. The current animation panel is using some jre 6 feature. It throw ClassNotFound, for example, java.awt.RadialGradientPaint.class, when run in 1.5.x jvm.

      To support multiple JREs, Animation Panel need take jre runtime version into consideration.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kbr Kenneth Russell (Inactive)
                Reporter:
                hdongorcl Hao Dong (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: